Closed Bug 1622974 Opened 6 months ago Closed 6 months ago

Update mozlint so it is able to use configuration files in an alternate path

Categories

(Firefox Build System :: Lint and Formatting, enhancement)

enhancement
Not set
normal

Tracking

(firefox76 fixed)

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: rjl, Assigned: rjl)

References

Details

Attachments

(2 files)

Many of the mozlint source-tests do not quite work for Thunderbird because of slightly different requirements, such as exclude lists.

I'm proposing adding a flag to mach mozlint to set an alternate path to check for the mozlint .yml files before checking the default path. This way Thunderbird builds change the necessary configurations and fall back to the ones in tools/lint.

Adds --extra-config-path parameter to mach mozlint where test configuration
files (.yml) can be located. The extra path has preference over the default.
This allows Thunderbird to run mozlint-based tests in Taskcluster with a
different configuration.

Assignee: nobody → rob
Status: NEW → ASSIGNED
Blocks: 1623907
Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/integration/autoland/rev/77217211afb5
Add mozlint parameter to set additional config file path. r=ahal
https://hg.mozilla.org/integration/autoland/rev/300ee1c92b54
Add global exclude file for Thunderbird mozlint tests. r=sylvestre
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76
Duplicate of this bug: 1612185
You need to log in before you can comment on or make changes to this bug.