Closed Bug 1623255 Opened 8 months ago Closed 7 months ago

Unknown protocol error should not be alerted by turning whole page into error page

Categories

(Firefox :: File Handling, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1528305

People

(Reporter: garywill, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

(On desktop or Android)
Visit some webs that both show the content and try to open that content in their own app by automatically navigating to uri like 'their-protocol://xxxxxxxxxxxxxxx'.

Actual results:

If the app is not installed so that protocol is not registered, the whole tab turns into an error page:
Problem loading page
The address wasn’t understood
[Try Again]

That makes user can't read the content neither on web or in app. The web is actually already showing the content, which firefox is blocking user to read.

Expected results:

Don't turn the whole page into error page. Alert unknown protocol error by dialog or something that won't override the tab, like other browsers do.

Version: 68 Branch → Trunk

Hello Gary,

Could you please provide more elaborate steps on this issue and also the websites/apps that you used and encountered the issue on?

Flags: needinfo?(garywill)

Marking this as Resolved > Incomplete due to the reporeter's lack of reply.

If the issue persists feel free to re-open this issue or file a new one with more detailed steps.

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Resolution: --- → INCOMPLETE

Hi Andrei,
Sorry for late reply.

Many apps register their own protocol scheme. Apple has itms://, itms-app://, Telegram has tg:// etc.

As for browser behavior, we can try open this html file in Firefox and other browsers:

<html><head><script type="text/javascript">
setTimeout(function(){
    window.location="myapp://my-path-to-this-content";
}, 2000);
</script>  </head>
<body><h2>
  Hello.<br> 
  If you are using Firefox, this web is usable for only 1 sec.<br> 
  If using other browsers, you will see a popup in 1 sec and this web is always usable.
</h2></body></html>

After Firefox's error page override the page, I tried to click go back button, it went back and then soon the error page overrides the page again.
Everytime I have to switch to other browsers to view such webs.

Although it's bad for a web to navigate like that, but there are really some websites doing that (I can't remember them now. I'll post it here if some day I find them again).

Flags: needinfo?(garywill)
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---

I was able to reproduce this only on release using your steps.
On Nightly and beta however it didn't redirect me to an error page. It just showed the message.

Setting a component for this enhancement in order to get the dev team involved.
If you feel it's an incorrect one please feel free to change it to a more appropriate one.

Component: Untriaged → File Handling

This was fixed in bug 1528305.

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1528305
You need to log in before you can comment on or make changes to this bug.