Closed Bug 1623583 Opened 2 years ago Closed 2 years ago

Home/End keys don't work in contenteditable in shadow root

Categories

(Core :: DOM: Editor, defect)

74 Branch
Unspecified
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1539376

People

(Reporter: brecht, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

Actual results:

Nothing

Expected results:

The cursor should jump to the start or end of the line, as is the case when doing this in the bottom contenteditable.

Possibly related to bug 1553852.

I tested this with Firefox 72.0.2 and 74.0 on Windows and Home/End keys work fine there, so this is a Mac-specific issue.

I haven't been able to check on Linux.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → DOM: Editor
Product: Firefox → Core

(In reply to Brecht Machie from comment #2)

I tested this with Firefox 72.0.2 and 74.0 on Windows and Home/End keys work fine there, so this is a Mac-specific issue.

I haven't been able to check on Linux.

Works with Firefox 75.0b5 on Ubuntu 18.04.

Blocks: shadowdom
OS: Unspecified → macOS
Flags: needinfo?(echen)

(In reply to Brecht Machie from comment #2)

this is a Mac-specific issue.

It doesn't work not only in contenteditable in shadow root, the it dones't work in light dom and browser UI (e.g. URL bar, search bar ..), either.
See https://bugzilla.mozilla.org/show_bug.cgi?id=1539376.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(echen)
Resolution: --- → DUPLICATE
Duplicate of bug: 1539376
You need to log in before you can comment on or make changes to this bug.