Closed Bug 1623597 Opened 11 months ago Closed 11 months ago

Distribution engines are not being marked as built-in engines (reappear after each update)

Categories

(Firefox :: Search, defect, P1)

defect
Points:
3

Tracking

()

RESOLVED FIXED
Firefox 76
Iteration:
76.2 - Mar 23 - Apr 5
Tracking Status
firefox-esr68 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- fixed

People

(Reporter: standard8, Assigned: standard8)

References

(Regression)

Details

(Keywords: perf-alert, regression)

Attachments

(1 file)

Distribution engines are currently not being marked as built-in.

We regressed this here in bug 1405670 (the changes in the two sections after the highlights):

https://searchfox.org/mozilla-central/diff/47b9babf07b15b7bb6f7e873c87cd2ceddd1d4ec/toolkit/components/search/nsSearchService.js#3383,3408

The main effect of this, is that if the user removes a built-in engine that has been added or modified by a distribution, then we'll re-add it after update.

STR

  1. With a Firefox distribution that is 59 or later, set up a profile, and remove one of the search engines that the distribution alters/adds.
  2. Upgrade to the same Firefox distribution that is based on 69 or earlier (69 has another bug that makes things worse).

Actual Results

The engine that was removed re-appears.

Expected Results

The engine that was removed stays hidden.

See Also: → 1623599
Iteration: 76.1 - Mar 9 - Mar 22 → 76.2 - Mar 23 - Apr 5
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/85b2d74f7451
Distribution engines should be marked as built-in so that their settings are saved. r=daleharvey
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76

== Change summary for alert #25518 (as of Mon, 30 Mar 2020 22:17:31 GMT) ==

Improvements:

19% raptor-tp6-binast-instagram-firefox fcp macosx1014-64-shippable opt 290.77 -> 234.17
16% raptor-tp6-binast-instagram-firefox macosx1014-64-shippable opt 386.18 -> 326.04
14% raptor-tp6-outlook-firefox-cold fcp macosx1014-64-shippable opt 324.83 -> 280.42
12% raptor-tp6-outlook-firefox-cold macosx1014-64-shippable opt 438.42 -> 384.68
11% raptor-tp6-google-firefox-cold loadtime macosx1014-64-shippable opt 1,745.25 -> 1,553.42
9% raptor-tp6-google-firefox-cold macosx1014-64-shippable opt 626.52 -> 568.72

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=25518

Keywords: perf-alert

Hi Florin, as much as I'd be happy to take credit for the perf improvements, I'm not convinced their mine. Unless those tests are doing something with distribution builds and search engines (which it doesn't look like), then this patch isn't related.

Looking at the related graphs, there seems to be in a lot of cases frequent dips in what the builders are reporting, and then they pop back up again. So I'm not sure, but this could be a false-positive.

Flags: needinfo?(fstrugariu)

Yep you are right re-triggered some tests and it looks like Bug 1578694 - Weekend performance spikes on mac
Sorry for the confustion

Flags: needinfo?(fstrugariu)
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.