Closed Bug 1623603 Opened 4 months ago Closed 4 months ago

Microsoft Online failing to log in

Categories

(Core :: Networking: Cookies, defect, P3)

76 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: hullmo, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [necko-triaged])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

Attempted to log in to our corporate website which uses our corporate AD credentials for authentication

Actual results:

It seemed to get stuck in a loop for a while and then fails to log in.

Expected results:

I would have been logged in to my corporate website.

Here is a mozregression output for this bug:

2020-03-19T08:47:09: DEBUG : Found commit message:
Bug 1604212 - Enable sameSite=lax by default, r=Ehsan,ahal

Differential Revision: https://phabricator.services.mozilla.com/D63081

2020-03-19T08:47:09: DEBUG : Did not find a branch, checking all integration branches
2020-03-19T08:47:09: INFO : The bisection is done.
2020-03-19T08:47:09: INFO : Stopped

Looking at the console log when attempting to log in I do see the following which seems related to that commit message.

Cookie “CkTst” has “sameSite” policy set to “lax” because it is missing a “sameSite” attribute, and “sameSite=lax” is the default value for this attribute. BrowserControl.js:836
Cookie “clrc” has “sameSite” policy set to “lax” because it is missing a “sameSite” attribute, and “sameSite=lax” is the default value for this attribute.

Please let me know if any additional info is needed.

Component: Untriaged → Networking: Cookies
Product: Firefox → Core
Priority: -- → P3
Regressed by: 1604212
Whiteboard: [necko-triaged]

Hey [:valentin}
I would like to work on this. Would be glad if you could guide me a little.
Thanks :)

Did anyone test with latest nightly?

Good call j.j. I tried with yesterday nightly build and it seems to be working again.

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.