All browser windows have the same X class.instance

VERIFIED DUPLICATE of bug 29856

Status

--
minor
VERIFIED DUPLICATE of bug 29856
16 years ago
14 years ago

People

(Reporter: pelzlpj, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.1b) Gecko/20020722
BuildID:    2002072204

All browser windows--including "find" dialogs, the download manager, "URL not
found" dialogs, etc.--use the same X-windows class and instance.  'xprop' always
reports:

WM_CLASS(STRING) = "mozilla-bin", "Mozilla-bin"

Ideally, different types of windows should have different instances.  That would
enable various window managers (e.g. ion) to give special treatment to specific
Mozilla windows.

Reproducible: Always
Steps to Reproduce:
Just run 'xprop' on any Mozilla window.

Actual Results:  'xprop' always reports:
WM_CLASS(STRING) = "mozilla-bin", "Mozilla-bin"

Expected Results:  Just as an example, a "find" dialog might report something like:
WM_CLASS(STRING) = "mozilla_find", "Mozilla-bin"

Mozilla is not very friendly to the Ion window manager
<http://modeemi.cs.tut.fi/~tuomov/ion/> at the moment.  Ion provides several
modes for handling transient windows.  If different modes were used for
different Mozilla windows, the problem would go away; that is only possible if
different types of Mozilla windows are given unique X instance identifiers.

Comment 1

16 years ago
*** Bug 162366 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 29856 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
V
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.