Closed Bug 1623936 Opened 4 months ago Closed 3 months ago

2.46 - 11.53% Base Content Explicit / Base Content Heap Unclassified / Explicit Memory / Heap Unclassified (linux1804-64-shippable-qr, windows10-64-shippable-qr) regression on push 97879e1e1dcb4c0577bb4ed4b7f803a9c236fc22 (Thu March 19 2020)

Categories

(Core :: Graphics: WebRender, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected
firefox76 --- fixed

People

(Reporter: marauder, Assigned: miko)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: perf, perf-alert, regression)

We have detected an awsy regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=97879e1e1dcb4c0577bb4ed4b7f803a9c236fc22

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

12% Heap Unclassified windows10-64-shippable-qr opt 57,812,902.04 -> 64,478,219.38
10% Heap Unclassified windows10-64-shippable-qr opt 57,966,141.79 -> 63,925,885.80
5% Base Content Heap Unclassified linux1804-64-shippable-qr opt 5,898,642.67 -> 6,182,442.00
3% Heap Unclassified windows10-64-shippable-qr opt tp6 71,892,872.83 -> 74,120,539.79
3% Explicit Memory windows10-64-shippable-qr opt 360,070,310.70 -> 370,934,308.29
2% Base Content Explicit linux1804-64-shippable-qr opt 13,068,288.00 -> 13,389,653.33

You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=25458

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/AWSY/Tests

Blocks: 1622755
Component: Performance → Graphics: WebRender
Flags: needinfo?(mikokm)
Product: Testing → Core
Regressed by: 1616412
Target Milestone: --- → mozilla76
Version: Version 3 → unspecified

This is to be expected. Bug 1616412 adds an additional cache in parent process for WebRender display lists. I have yet to hook this up with memory reporting.

Flags: needinfo?(mikokm)

(In reply to Miko Mynttinen [:miko] from comment #1)

This is to be expected. Bug 1616412 adds an additional cache in parent process for WebRender display lists. I have yet to hook this up with memory reporting.

Can you please file a blocking bug to track memory usage? Additionally it looks like we saw an increase in the base measurement on Linux as well, so about:blank in a content process. Any chance your changes are inadvertently affecting content processes as well?

Flags: needinfo?(mikokm)

(In reply to Eric Rahm [:erahm] from comment #2)

(In reply to Miko Mynttinen [:miko] from comment #1)

This is to be expected. Bug 1616412 adds an additional cache in parent process for WebRender display lists. I have yet to hook this up with memory reporting.

Can you please file a blocking bug to track memory usage? Additionally it looks like we saw an increase in the base measurement on Linux as well, so about:blank in a content process. Any chance your changes are inadvertently affecting content processes as well?

Filed bug 1624016.

Item caching also stores some additional state1 on the content process side. The initial overhead should be around 20KB per content process, but it can grow if those content processes encounter display lists that contain a lot of cacheable items. This is probably not a very common case outside of benchmarks.

Flags: needinfo?(mikokm)
Depends on: 1624016
Assignee: nobody → mikokm
Status: NEW → ASSIGNED
Priority: -- → P2
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.