Closed Bug 162404 Opened 19 years ago Closed 19 years ago

XHTML documents don't display progressively

Categories

(Core :: XML, defect, P3)

PowerPC
macOS
defect

Tracking

()

VERIFIED DUPLICATE of bug 18333
Future

People

(Reporter: bugmail, Assigned: hjtoi-bugzilla)

Details

(Keywords: xhtml)

Attachments

(2 files)

609 bytes, application/xhtml+xml
Details
609 bytes, text/html
Details
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020722
BuildID:    2002072203

An XHTML document, served as application/xml, and with some text before a
script, doesn't display that text before executing the script. The same page
does display as expected when served as text/html.

Reproducible: Always
Steps to Reproduce:
1. Access the XHTML testcase (to be attached)

Actual Results:  The text paragraph doesn't draw prior to the JavaScript alert
being displayed.

Expected Results:  The text paragraph should have been drawn prior to the
JavaScript alert being displayed.
Attached file XHTML Testcase
Attached file HTML Testcase
Keywords: xhtml
This is very likely a sink/parser issue, not a layout issue.
Priority: -- → P3
Target Milestone: --- → Future
Reassigning to Parser per comment 3.
Assignee: attinasi → harishd
Component: Layout → Parser
QA Contact: petersen → moied
"Parser" is really only for the HTML parser. This is an XML bug.
Assignee: harishd → heikki
Component: Parser → XML
QA Contact: moied → petersen

*** This bug has been marked as a duplicate of 18333 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
QA Contact: petersen → rakeshmishra
Attachment #95027 - Attachment mime type: application/xml → application/xhtml+xml
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.