Closed Bug 1624181 Opened 5 months ago Closed 3 months ago

`getDisplayMedia` is not undefined but always returns a promise that is immediately rejected (as capturing the screen is not supported on Android)

Categories

(Core :: WebRTC: Audio/Video, defect, P2)

68 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: lukas.kalbertodt, Assigned: jib)

Details

(Keywords: parity-chrome)

Attachments

(2 files)

Attached file index.html

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.116 Safari/537.36

Steps to reproduce:

Open the attached HTML file in Firefox for Android 68. Then click the button to actually call getDisplayMedia.

Actual results:

getDisplayMedia is defined. When clicking the button, Firefox does not prompt the user to share their screen, but instead immediately rejects the promise returned by getDisplayMedia.

Expected results:

The function getDisplayMedia should be undefined so that websites can check if that feature is supported by the browser+OS.

I initially asked about this on StackOverflow. As response to this, an issue on the w3c repo was created. There people pointed out that this should be treated as bug. There is also already a chromium bug report. But since I couldn't find a bug report for Firefox, I created this.

Status: UNCONFIRMED → NEW
Component: Screencasting → WebRTC: Audio/Video
Ever confirmed: true
Priority: -- → P2
Product: Firefox for Android → Core
Version: Firefox 68 → 68 Branch
Attachment #9142515 - Attachment description: Bug 1624181 - Omit getDisplayMedia() function on android due to aid feature detection. → Bug 1624181 - Omit getDisplayMedia() function on android to aid feature detection.
Assignee: nobody → jib
Status: NEW → ASSIGNED
Pushed by jbruaroey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f22a6cf0ce62
Omit getDisplayMedia() function on android to aid feature detection. r=dminor,snorp,webidl,smaug
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
Flags: qe-verify+

Tested with Samsung Galaxy Note10 (Android 10) and Nokia 6 (Android 7.1.1) following the steps from the description and from comment 3 on the latest Fenix Nightly 77.0a1 - 5/7.
Results: 'getDisplayMedia' is defined:no and "TypeError: navigator.mediaDevices.getDisplayMedia is not a function".

Flags: needinfo?(jib)

👍

Flags: needinfo?(jib)
You need to log in before you can comment on or make changes to this bug.