Closed Bug 1624290 Opened 2 years ago Closed 2 years ago

[Wayland] DMABuf WebGL crash @ gbm_create_device() (AMD Picasso APU)

Categories

(Core :: Widget: Gtk, defect, P3)

76 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1624743
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- disabled
firefox75 --- disabled
firefox76 --- disabled

People

(Reporter: greyxor, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

Hello everyone,
i've followed the activation procedure for wayland dmabuf backend for webgl on Martin's blog(https://mastransky.wordpress.com/2020/03/03/webgl-and-fgx-acceleration-on-wayland/)
I set widget.wayland-dmabuf-webgl.enabled
restart firefox
open a webgl demo (https://webglsamples.org/aquarium/aquarium.html for example)

Actual results:

Tab crash and this is my crash report :

https://crash-stats.mozilla.org/report/index/de5fac34-14a7-4ccd-8242-0e68f0200323
https://crash-stats.mozilla.org/report/index/c378c160-f421-48d0-a7d0-4bab30200323

If I reset widget.wayland-dmabuf-webgl.enabled to false. The demo working again.

Expected results:

WebGL demo working

Component: Untriaged → Canvas: WebGL
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64
Crash Signature: [@ libc.so.6@0xf9f8d | libgallium_dri.so@0x47d6a8 ]
Keywords: crash
Summary: [Wayland] DMABuf WebGL crash → [Wayland] DMABuf WebGL crash (AMD Picasso APU)

It crashes here:
https://searchfox.org/mozilla-central/rev/202a285024f174c2d2bf2152d9cba90a03723eab/widget/gtk/nsWaylandDisplay.cpp#371

It crashes at gbm_create_device() call. I wonder what can be wrong here, maybe wrong DRM device or so?

Summary: [Wayland] DMABuf WebGL crash (AMD Picasso APU) → [Wayland] DMABuf WebGL crash @ gbm_create_device() (AMD Picasso APU)

Can you attach your about:support please?

Flags: needinfo?(greyxor)
Component: Canvas: WebGL → Widget: Gtk
Priority: -- → P3

(In reply to Martin Stránský [:stransky] from comment #2)

Can you attach your about:support please?
Thanks for the feedback, I've added my about:support just above.

I don't know if that help but :
i'm using Sway and all my about:config is default but
network.security.esni.enabled true
gfx.webrender.all true
widget.wayland-dmabuf-webgl.enabled true

I have AMD Ryzen 3500U (ThinkPad t495s)
Arch Linux (5.6.0-rc7-1-mainline)

Flags: needinfo?(greyxor)

I don't see anything strange here. Can you try to install mesa-dri debug info packages (for the libgallium_dri.so library) and try to get a backtrace by gdb? Some how-to is here:
https://fedoraproject.org/wiki/Debugging_guidelines_for_Mozilla_products#Application_crash
(this one is for Fedora but should apply to other distros too).
Thanks.

Flags: needinfo?(greyxor)
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(greyxor)
Resolution: --- → DUPLICATE
Duplicate of bug: 1624743
You need to log in before you can comment on or make changes to this bug.