Trouble recognizing that an item is an image

VERIFIED INVALID

Status

()

Core
Layout
VERIFIED INVALID
16 years ago
16 years ago

People

(Reporter: Kyle Bieneman, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607
BuildID:    0000000000

Mozilla fails to recognize what certain items are, and defaults to displaying
them as ASCII text.  In this particular instance, it is a GIF image that is
displayed as text, though I have also encountered the problem with DivX movies.
 The page above may not be very useful, as the site requires registration, but I
don't have a webpage, so unfortunately I can't mirror the image.

Reproducible: Always
Steps to Reproduce:
1. Visit
http://www.freetrainers.com/FT/servlet/FreeTrainers?action=FTChart&exercise=Incline_Seated_Calf_Raises

Actual Results:  I see the text string "GIF89a" (w/out quotes) followed by a
page of garbage text.

Expected Results:  I should have seen a pretty graph demonstrating my ever
increasing weight lifting ability.

Works in IE under Windows, so I know that the image is not corrupted.

Comment 1

16 years ago
check the mime/type is not text/plain or text/html for images.

Comment 2

16 years ago
The provided URL dosn't work, it just sends -nothing- (tested with mozilla and wget)

But as Olivier said:
It seems like the webserver is broken and sends a wrong Content-Type..
If the MimeType is text/hml .. text/plain, mozilla does the right thing and
displays the image as text or html ... .. so it would be INVALID (because
mozilla does what the server told us to do)

Comment 3

16 years ago
Please save the image to disk and then upload it as an attachment to this
bug report using URL below. Thanks.
http://bugzilla.mozilla.org/attachment.cgi?bugid=162443&action=enter
(Reporter)

Comment 4

16 years ago
Ah, yes, the mime/type appears to be the problem.  Sorry to waste everyone's time.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 5

16 years ago
-> VERIFIED
Broken CGI Script
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.