Closed Bug 1624612 Opened 4 months ago Closed 3 months ago

Validation button is not displayed by default in certificate management window

Categories

(Firefox :: Preferences, defect)

74 Branch
x86_64
Windows 10
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 77
Tracking Status
firefox-esr68 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- verified

People

(Reporter: tristan.laurent96, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

In firefox settings with firefox in French language (the bug is not present when using english version), go to "Vie privée et sécurité", go at the bottom of the page, open the certificate manager using the "Afficher le certificats" button

Actual results:

By default the "Ok" button to validate is not displayed (we have to enlarge the window)

Expected results:

"Ok" button displayed by default

Component: Untriaged → Preferences
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Flags: needinfo?(bgrinstead)
Keywords: regression
Regressed by: 1500626
Flags: needinfo?(bgrinstead)
Keywords: regression
No longer regressed by: 1500626
Flags: needinfo?(gijskruitbosch+bugs)

This was definitely already broken on Jan 1, 2019, and was working on Nov 27, 2018. On Nov 28, we landed bug 1498448, which switched this dialog to fluent. It was a bit of a pain, but I tested the Nov 28 build with a french langpack from the evening of Nov 30 (by which time french strings were available) and... the dialog was fine.

Anyway, I proceeded to run mozregression (I should maybe blog about how to do that for locale-specific issues? It was a bit of a nightmare...), and I think we regressed this in bug 1515109. Which is much more dumb and much less complicated than fluent or race conditions - we reduced the width, and didn't realize that in French, the strings are much longer. :-\

That said, if we increase the width significantly, I bet we basically run into bug 1515109 again. The dialog then won't really fit in the viewport very well...

In local testing, 48em (current is 40em, was 63em) is sufficient for French, so perhaps we should just update to that, or make the value localizable. But I'd rather we come up with a better solution... Jared, do you have ideas? Perhaps we can come up with a way of opting subdialogs into "size me as wide as you can given the viewport (with some sensible default maximum like 80em or whatever)" ?

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(jaws)
Keywords: regression
Regressed by: 1515109

Can you test with putting min-width: inherit; on .dialogFrame and overflow-x: auto; on .dialogBox?

Flags: needinfo?(jaws) → needinfo?(gijskruitbosch+bugs)

(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #2)

Can you test with putting min-width: inherit; on .dialogFrame and overflow-x: auto; on .dialogBox?

Jared, here is the test with your changes in css. It is better, we can see a part of the button but still not all the window
https://send.firefox.com/download/a1bd10a7b16e6283/#otfDSPN7vb5N2gPs-2oOEw

Attached image firefoxBug.png

Attaching the file from comment 2 so it's easier to see :-)

(In reply to :Gijs (he/him) from comment #4)

Attaching the file from comment 2 so it's easier to see :-)

So I can repro this, but it works properly if I remove the width and height currently set on the document from the markup (so it's not there when the dialog loads). Which makes sense - there's code that determines the dialog's size before showing it and then resizes the subframe so it fits. I'll put up a patch for this.

Flags: needinfo?(gijskruitbosch+bugs)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0ce30c340f78
fix sizing of the cert manager dialog, r=jaws,keeler
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77

The patch landed in nightly and beta is affected.
:Gijs, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.
If yes, don't forget to request an uplift for the patches in the regression caused by this fix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(gijskruitbosch+bugs)

I regressed something with the patch, so I'd rather this rode the trains, unfortunately.

Flags: needinfo?(gijskruitbosch+bugs)
Flags: qe-verify+

Reproduced this bug using an affected Nightly french build (from 2020-03-24), on Win 10 x64.

The "OK" button is correctly displayed on latest Beta 77.0b9 french build, across platforms: Win 10 x64, macOS 10.15 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.