openDialog is being used for non-dialogs. It shouldn't be.
Assignee: cmanske → danm
Status: ASSIGNED → NEW
Summary: openDialog should not be used for non-dialogs. → openDialog method should be renamed
Target Milestone: M11 → M12
We need the functionality of openDialog to pass a URL to be loaded into a specific window type. So the real problem is not that openDialog shouldn't be used for non-dialogs, but that the name should be changed to something more appropriate, such as openWithArgs.
Can't you do that with the CGI-bin chrome URL syntax?
mass-moving all m12 bugs to m13
Updating QA Contact
QA Contact: leger → paulmac
Mass-moving all M16 non-feature bugs to M17, which we still consider to be part of beta2
Target Milestone: M16 → M17
changing qa contact to firstname.lastname@example.org on some random bugs
QA Contact: paulmac → jrgm
moving to m18
Target Milestone: M17 → M18
mass-moving all bugs to m21 that are not dofood+, or nsbeta2+
Target Milestone: M18 → M21
Sigh. Too late.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.