Closed Bug 1624889 Opened 5 months ago Closed 5 months ago

Opening RDM from the Style Editor does not set the viewport dimensions specified by the media query

Categories

(DevTools :: Responsive Design Mode, defect, P1)

defect

Tracking

(firefox-esr68 unaffected, firefox74 unaffected, firefox75 unaffected, firefox76 verified)

VERIFIED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- unaffected
firefox75 --- unaffected
firefox76 --- verified

People

(Reporter: mtigley, Assigned: mtigley)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR

  1. Go to any website with screen min/max-width media queries specified in their stylesheet.
  2. Open the Style Editor and click on any of the media query links to open RDM.

Expected
RDM opens with the viewport dimensions set to the media query values

Actual
RDM ignores the viewport dimensions it was opened with. It just shows the values previously selected.

This was regressed by Bug 1621306 when fixing the style editor test because the call to RDM UI's setViewportSize was moved into the test instead of keeping it in https://searchfox.org/mozilla-central/source/devtools/client/styleeditor/StyleEditorUI.jsm#1103. See: https://phabricator.services.mozilla.com/D66246

Priority: -- → P1
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/22baf134cf80
Ensure RDM sets the viewport width and height when opened from the Style Editor r=bradwerth
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76

This issue is Verified as Fixed in our latest Nightly build 76.0a1 (2020-03-30) On Windows 10, MAC 10.15 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.