Closed Bug 1624909 Opened 4 months ago Closed 2 months ago

Position of radio button and required attribute not reported

Categories

(Core :: Disability Access APIs, defect, P1)

All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox78 --- verified

People

(Reporter: eeejay, Assigned: morgan)

Details

(Whiteboard: [mac2020_1])

Attachments

(1 file)

STR:

  1. Open: data:text/html,<fieldset><legend>Animal</legend><input type="radio" name="animal" value="cat" id="cat" aria-required="true"><label for="cat">Cat</label><input type="radio" name="animal" value="dog" id="dog" aria-required="true"><label for="dog">Dog</label><input type="radio" name="animal" value="catdog" id="catdog" aria-required="true"><label for="catdog">CatDog</label></fieldset>
  2. Navigate through radio buttons

Expected: Should hear role, name, required and position

Actual: Only role and name are spoken

Notes:
aria radiogroups have the same issue.

Assignee: nobody → mreschenberg
Priority: P2 → P1
Attachment #9143797 - Attachment description: Bug 1624909: Create and maintain radio siblings array for position information. r=eeejay → Bug 1624909: Create and maintain radio siblings relation for position information. r=eeejay
Attachment #9143797 - Attachment description: Bug 1624909: Create and maintain radio siblings relation for position information. r=eeejay → Bug 1624909: Create and maintain radio siblings array for position information. r=eeejay
Severity: normal → S3
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d9a39c63e40e
Create and maintain radio siblings array for position information. r=eeejay

Backed out changeset d9a39c63e40e (bug 1624909) for Pivot.h related bustages

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&fromchange=d9a39c63e40e11af2cc13304f28b4a00fafc1dc5&searchStr=build&tochange=0261162195643a968c73bdeffa0d8db3bfd38aec&selectedTaskRun=NMoDOR9lTX2n_A4wJNq9Qg-0

Backout link: https://hg.mozilla.org/integration/autoland/rev/0261162195643a968c73bdeffa0d8db3bfd38aec

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=303296810&repo=autoland&lineNumber=46297

[task 2020-05-21T23:50:09.698Z] 23:50:09     INFO -  make[4]: Entering directory '/builds/worker/workspace/obj-build/accessible/base'
[task 2020-05-21T23:50:09.698Z] 23:50:09     INFO -  /builds/worker/fetches/sccache/sccache /builds/worker/fetches/clang/bin/clang++ -std=gnu++17 -o Unified_cpp_accessible_base0.o -c  -I/builds/worker/workspace/obj-build/dist/stl_wrappers -I/builds/worker/workspace/obj-build/dist/system_wrappers -include /builds/worker/checkouts/gecko/config/gcc_hidden.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -DNDEBUG=1 -DTRIMMED=1 -DOS_POSIX=1 -DOS_LINUX=1 -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DSTATIC_EXPORTABLE_JS_API -I/builds/worker/checkouts/gecko/accessible/base -I/builds/worker/workspace/obj-build/accessible/base -I/builds/worker/checkouts/gecko/accessible/generic -I/builds/worker/checkouts/gecko/accessible/html -I/builds/worker/checkouts/gecko/accessible/ipc -I/builds/worker/checkouts/gecko/dom/base -I/builds/worker/checkouts/gecko/dom/xul -I/builds/worker/checkouts/gecko/accessible/ipc/other -I/builds/worker/checkouts/gecko/accessible/xpcom -I/builds/worker/checkouts/gecko/accessible/xul -I/builds/worker/checkouts/gecko/dom/base -I/builds/worker/checkouts/gecko/ipc/chromium/src -I/builds/worker/checkouts/gecko/layout/generic -I/builds/worker/checkouts/gecko/layout/style -I/builds/worker/checkouts/gecko/layout/svg -I/builds/worker/checkouts/gecko/layout/xul -I/builds/worker/checkouts/gecko/layout/xul/tree -I/builds/worker/checkouts/gecko/accessible/atk -I/builds/worker/workspace/obj-build/ipc/ipdl/_ipdlheaders -I/builds/worker/checkouts/gecko/ipc/chromium/src -I/builds/worker/checkouts/gecko/ipc/glue -I/builds/worker/workspace/obj-build/dist/include -I/builds/worker/workspace/obj-build/dist/include/nspr -I/builds/worker/workspace/obj-build/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/obj-build/mozilla-config.h -Qunused-arguments -Qunused-arguments -Wall -Wbitfield-enum-conversion -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wempty-init-stmt -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Wunused-function -Wunused-variable -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wtautological-unsigned-enum-zero-compare -Wtautological-unsigned-zero-compare -Wno-error=tautological-type-limit-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=backend-plugin -Wno-error=return-std-move -Wno-error=atomic-alignment -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -fno-aligned-new -fcrash-diagnostics-dir=/builds/worker/artifacts -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/obj-build/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -O2 -fno-omit-frame-pointer -funwind-tables -Werror -I/builds/worker/workspace/obj-build/dist/include/cairo -Wno-error=shadow -fexperimental-new-pass-manager  -MD -MP -MF .deps/Unified_cpp_accessible_base0.o.pp   Unified_cpp_accessible_base0.cpp
[task 2020-05-21T23:50:09.698Z] 23:50:09     INFO -  In file included from Unified_cpp_accessible_base0.cpp:128:
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -  In file included from /builds/worker/checkouts/gecko/accessible/base/Pivot.cpp:6:
[task 2020-05-21T23:50:09.701Z] 23:50:09    ERROR -  /builds/worker/checkouts/gecko/accessible/base/Pivot.h:91:3: error: bad implicit conversion constructor for 'PivotRoleRule'
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -    PivotRoleRule(mozilla::a11y::role aRole);
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -    ^
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -  /builds/worker/checkouts/gecko/accessible/base/Pivot.h:91:3: note: consider adding the explicit keyword to the constructor
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -    PivotRoleRule(mozilla::a11y::role aRole);
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -    ^
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -    explicit
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -  In file included from Unified_cpp_accessible_base0.cpp:128:
[task 2020-05-21T23:50:09.701Z] 23:50:09    ERROR -  /builds/worker/checkouts/gecko/accessible/base/Pivot.cpp:539:16: error: bad implicit conversion constructor for 'PivotRoleRule'
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -  PivotRoleRule::PivotRoleRule(mozilla::a11y::role aRole) : mRole(aRole) {}
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -                 ^
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -  /builds/worker/checkouts/gecko/accessible/base/Pivot.cpp:539:16: note: consider adding the explicit keyword to the constructor
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -  PivotRoleRule::PivotRoleRule(mozilla::a11y::role aRole) : mRole(aRole) {}
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -                 ^
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -                 explicit
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -  2 errors generated.
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -  /builds/worker/checkouts/gecko/config/rules.mk:746: recipe for target 'Unified_cpp_accessible_base0.o' failed
[task 2020-05-21T23:50:09.701Z] 23:50:09    ERROR -  make[4]: *** [Unified_cpp_accessible_base0.o] Error 1
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -  make[4]: Leaving directory '/builds/worker/workspace/obj-build/accessible/base'
[task 2020-05-21T23:50:09.701Z] 23:50:09     INFO -  make[4]: *** Waiting for unfinished jobs....
Flags: needinfo?(mreschenberg)
Flags: needinfo?(mreschenberg)
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b4c58d9afd4b
Create and maintain radio siblings array for position information. r=eeejay
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/156d42f01488
Create and maintain radio siblings array for position information. r=eeejay
Flags: needinfo?(mreschenberg)

omg I'm sorry why is this so hard

Flags: needinfo?(mreschenberg)
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d2b10235d8ac
Create and maintain radio siblings array for position information. r=eeejay
Pushed by mreschenberg@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1780b3e8a63c
Create and maintain radio siblings array for position information. r=eeejay
Flags: needinfo?(mreschenberg)
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Flags: qe-verify+

Reproduced the issue using Firefox 76.0a1 (20200325213906) on macOS 10.12.
The issue is verified fixed using Firefox 78.0b7 (20200612174529) on macOS 10.12.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.