Closed Bug 1624992 Opened 3 years ago Closed 2 years ago

Skip processing updates when starting up to run the browser toolbox

Categories

(Toolkit :: Application Update, enhancement, P3)

Desktop
Unspecified
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1120863

People

(Reporter: mhowell, Unassigned)

References

Details

(Whiteboard: [iu_tracking])

The browser toolbox runs in a fresh instance of Firefox with its own profile. Since it is (mostly) a normal browser instance, it processes updates during startup, and will finish any that it finds in the pending or applied states. This means that simply running the dev tools can get you into the situation that bug 1366808 is about, where an update is applied to one instance while another instance is running, leaving that other instance in an inconsistent and unpredictably broken state.

In general that problem is a hard one to solve (which is why bug 1366808 papered over it with an error message instead), but in this specific case, it seems pretty clear that we can just not do anything involving updates inside the browser toolbox instance. We should disable startup processing and the entire update service (to the extent possible) in that case.

Summary: Skip processing updates when starting up to run dev tools → Skip processing updates when starting up to run the browser toolbox
See Also: → 1553982
Whiteboard: [iu_tracking]

Unless there's some finer point I missed, I think this is what was done to solve bug 1120863.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120863
You need to log in before you can comment on or make changes to this bug.