Closed Bug 1625173 Opened 4 years ago Closed 4 years ago

Hit-testing produces incorrect result with SVG over iframe element

Categories

(Core :: Panning and Zooming, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Fission Milestone M7
Tracking Status
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- fix-optional

People

(Reporter: kats, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [apz:fission:6:M])

Attachments

(2 files)

Attached file Testcase

Spinoff from https://bugzilla.mozilla.org/show_bug.cgi?id=1544451#c7. In the attached testcase, putting the mouse over the SVG bounding box (which is larger than the bounding box of the green circle) and doing a scrollwheel/trackpad scroll should scroll the root document. Chrome does this correct, we do not. In Firefox (with WR on or off) putting the mouse inside the green circle's bounding box and scrolling does the right thing, but putting it in the space between the green circle's bounding box and the full SVG bounding box ends up scrolling the iframe instead of the root document.

Preliminary investigation in bug 1544451 has a display list dump here which seems to indicate that the SVGOuterSVG element isn't generating the compositor hit info item which one would expect it to.

No longer blocks: 1625249
See Also: → 1625249
Whiteboard: [apz:fission:6:M]

Tentatively tracking APZ Fission bugs for Fission Beta milestone (M7).

Fission Milestone: --- → M7

btw, we plan to allow Fission on macOS and Linux without WR (and may need to support Fission on Windows without WR), so we will want to test APZ bugs both with and without WR.

Kats, I can't reproduce the issue here even on older builds (I've checked builds since 2019-04-26). I was suspecting the fission attribute on the iframe element no longer works in these days, but it's not the case. I will attach a new test case which doesn't use the attribute.

Anyways, I might be misunderstanding what the issue is actually, so can you please check whether the issue still persists or not?

Flags: needinfo?(kats)

IIRC the bug as originally filed was for non-fission. The STR aren't totally clear, but you have to scroll the iframe to activate it first, and then scroll with the mouse just to the left of the blue box. With that I can reproduce the bug on older macOS nightlies, but as of bug 1534549 it seems fixed (for both WR and non-WR).

I also tried running in the WR+fission configuration but AFAICT the pid of the iframe is the same as the pid of tab, which means the iframe is not actually getting fission-ized. So I don't think the test is exercising anything different with fission enabled.

I would call this fixed by bug 1534549.

Depends on: 1534549
Flags: needinfo?(kats)

Thank you Kats! Closing as FIXED.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: