Closed Bug 1625196 Opened 4 years ago Closed 4 years ago

Support select[multiple] element in VoiceOver

Categories

(Core :: Disability Access APIs, defect, P1)

All
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox78 --- verified

People

(Reporter: eeejay, Assigned: eeejay)

Details

(Whiteboard: [mac2020_1])

Attachments

(3 files, 1 obsolete file)

STR:

  1. Load data:text/html,<select aria-label="food" multiple><optgroup label="Fruits"><option>apple</option><option>banana</option></optgroup><optgroup label="Meats"><option>Chicken</option><option>Steak</option></optgroup><optgroup label="Veggies" disabled=""><option>Broccoli</option><option>Lettuce</option></optgroup><option>Everything</option><option disabled="">Nothing</option></select>
  2. navigate to listbox

Expected:

  • Listbox should be an interaction group with selectable items

Actual:

  • Each item in the listbox is navigated

Notes:
There is much more nuance about how items are selected/deselected/add to selection, and how items are reported as selected. That should be part of the scope of this bug. I don't think Safari or Chrome do a great job with this.

Assignee: nobody → eitan
Priority: P2 → P1

Platform accessibles from proxies were not getting pruned. Also, there is no need
to walk up ancestors to find a pruning container since all pruning containers have direct
leaf children.

This is needed since selection is done by setting attributes.

Depends on D72482

Allow intermediate accessibles to be skipped the heirarchy and not have a native accessible.

It is still the responsibility of the first native ancestor of the accessible to parent it, but since the children of skipped containers are not special and don't have a specific role, we need to support their parent getter in the base class.

Depends on D72483

Attachment #9143263 - Attachment is obsolete: true
Severity: normal → S3
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b6d6f0350b4a
Prune proxy accessibles with nsAccUtils::MustPrune(). r=morgan
https://hg.mozilla.org/integration/autoland/rev/55270159595c
Add attribute setting methods to nsIAccessibleMacInterface. r=morgan
https://hg.mozilla.org/integration/autoland/rev/67530461c510
Support select[multiple] and role=listbox/option. r=morgan
Flags: qe-verify+

Confirmed issue with 77.0.1.
Fix verified with 78.0b7 on macOS 10.15.5

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: