Closed Bug 1625241 Opened 8 months ago Closed 8 months ago

Firefox doesn't update to the latest version if the "Restart to update" button is clicked while the update download process is still running

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 76
Tracking Status
firefox-esr68 --- unaffected
firefox74 --- disabled
firefox75 --- verified
firefox76 --- verified

People

(Reporter: emilghitta, Assigned: harry)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

Attached image updateFirefox.gif

Affected versions

  • Updates on Firefox beta channel (For Fx 75.0b_x)
  • Updates on Firefox nightly channel ( For Fx 76.0a_x)

Unaffected versions

  • Firefox 68.6.0esr (BuildId:20200305175243).
  • Firefox 74.0 (disabled).

Affected platforms

  • macOS 10.14
  • Windows 10 64bit
  • Ubuntu 18.04 64bit.

Steps to reproduce

In order to easily reproduce this issue you can simulate a poor internet connection by using softwares like NetLimiter.

  1. Launch an older version of Firefox (ex. 75.0b7).
  2. Type “update firefox” inside the Address Bar.
  3. Click the “Restart to Update” button while the update download process is still running.

Expected result

  • Firefox restarts and the latest version is installed.

Actual result

  • If the update download was not completed when the “Restart to Update” button was pressed Firefox simply restarts and the user doesn’t have the latest Firefox version.

Notes

  • This may generate user confusion since the intervention card prompts the user that “The latest Firefox is downloaded and ready to install” but the update download process was not finished and Firefox simply restarts with the same (old) version after interacting with the "Restart to Update" button.

Verdi, how do you want to handle this case?

One possibility is showing a tip with a greyed out "Restart to Update" button that says something like "The latest Firefox is downloading. Please wait to restart." (That string is probably in need of some Content Strategy magic). If the user kept the Urlbar panel open, we could swap out that tip for the usual Restart to Update tip when the download is done.

Flags: needinfo?(mverdi)
Keywords: blocked-ux
Priority: -- → P2
Points: --- → 3

Short of improving the feature to include the downloading status and changing the text as the status changes we can fall back to the we-don't-have-enough-information scenario which is to display a "Download Now" button with the copy "Get the latest Firefox browser." https://docs.google.com/document/d/1pN0y8TkadgeQHF3k-t-sPDWHkfXTyno7tjAQf-IUtU0/edit#

Flags: needinfo?(mverdi)
Assignee: nobody → htwyford
Status: NEW → ASSIGNED

Looks like we have UX input, so I'll remove the blocked-ux keyword. Thanks Verdi.

Keywords: blocked-ux
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/650f13016b6b
Show the UPDATE_ASK intervention if an update is still downloading or staging. r=adw
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76

Comment on attachment 9136914 [details]
Bug 1625241 - Show the UPDATE_ASK intervention if an update is still downloading or staging. r?adw

Beta/Release Uplift Approval Request

  • User impact if declined: The user would see a prompt to update the browser that wouldn't work. Users might think they're on the latest version when they are not.

This patch is part of the address bar update work in 75.

  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0.

When the update is still downloading, the "update firefox" query should show an intervention that just prompts the user to Download Firefox.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): 2-line change that this just shows different types of Interventions in the Urlbar for some queries. The changes are scoped entirely to Urlbar Interventions and it would not impact other Urlbar functionality.
  • String changes made/needed:
Attachment #9136914 - Flags: approval-mozilla-beta?
Flags: qe-verify+

We've already built a release candidate for 75. How critical is this?

Flags: needinfo?(htwyford)

It's not super critical. I'd classify it as polish, albeit pretty safe polish. It's okay if this doesn't get into beta.

Flags: needinfo?(htwyford)

Comment on attachment 9136914 [details]
Bug 1625241 - Show the UPDATE_ASK intervention if an update is still downloading or staging. r?adw

Thanks. I'll keep it on the radar in case we need to respin anyway.

Attachment #9136914 - Flags: approval-mozilla-beta? → approval-mozilla-release?
QA Whiteboard: [qa-triaged]

Comment on attachment 9136914 [details]
Bug 1625241 - Show the UPDATE_ASK intervention if an update is still downloading or staging. r?adw

Approving for 75.0rc2 on Julien's behalf.

Attachment #9136914 - Flags: approval-mozilla-release? → approval-mozilla-release+
Blocks: 1627672

Verified the fix on:

75.0 20200403064226 RC2
76.0a1 20200405212522

using:
Ubuntu 18.04
macOS 10.13
Windows 10

with the note that bug 1627702 has been logged in the process. Note that bug 1627702 is a behavior that is not regressed by this fix.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
You need to log in before you can comment on or make changes to this bug.