Closed Bug 1625660 Opened 4 months ago Closed 3 months ago

Update wat crate to 1.0.13 (actually probably 1.0.14)

Categories

(Core :: Javascript: WebAssembly, task, P3)

task

Tracking

()

RESOLVED DUPLICATE of bug 1624363

People

(Reporter: lth, Assigned: lth)

References

Details

Attachments

(3 obsolete files)

1.0.13 adds support for the new integer abs opcodes.

Blocks: 1478632
No longer blocks: wasm-simd
Pushed by lhansen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/64918c6e2f83
Update the wat crate to 1.0.13.  r=rhunt

Backed out changeset 64918c6e2f83 (Bug 1625660) for causing spidermonkey failures at build/src/js/src/jit-test/lib/asserts.js

Push with failure: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=295416014&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=64918c6e2f834f6e2f26cc9493e8f50c15c01124

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=295416014&repo=autoland&lineNumber=42718

Backout link: https://treeherder.mozilla.org/#/jobs?repo=autoland&selectedJob=295416014&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=ed3f1aeefd43f841e329f40b86371730c18aad8b

[task 2020-03-30T17:52:43.016Z] TEST-PASS | js/src/jit-test/tests/wasm/caching.js | Success (code 59, args "--wasm-compiler=baseline") [0.3 s]
[task 2020-03-30T17:52:43.164Z] TEST-PASS | js/src/jit-test/tests/wasm/caching.js | Success (code 0, args "--blinterp-eager") [1.9 s]
[task 2020-03-30T17:52:43.526Z] /builds/worker/workspace/build/src/js/src/jit-test/lib/asserts.js:69:15 Error: Assertion failed: expected exception SyntaxError, no exception thrown
[task 2020-03-30T17:52:43.527Z] Stack:
[task 2020-03-30T17:52:43.528Z]   assertErrorMessage@/builds/worker/workspace/build/src/js/src/jit-test/lib/asserts.js:69:15
[task 2020-03-30T17:52:43.528Z]   @/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/comments.js:28:19
[task 2020-03-30T17:52:43.529Z] Exit code: 3
[task 2020-03-30T17:52:43.530Z] FAIL - wasm/comments.js
[task 2020-03-30T17:52:43.530Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/wasm/comments.js | /builds/worker/workspace/build/src/js/src/jit-test/lib/asserts.js:69:15 Error: Assertion failed: expected exception SyntaxError, no exception thrown (code 3, args "") [0.4 s]
[task 2020-03-30T17:52:43.531Z] INFO exit-status     : 3
[task 2020-03-30T17:52:43.532Z] INFO timed-out       : False
[task 2020-03-30T17:52:43.532Z] INFO stderr         2> /builds/worker/workspace/build/src/js/src/jit-test/lib/asserts.js:69:15 Error: Assertion failed: expected exception SyntaxError, no exception thrown
[task 2020-03-30T17:52:43.533Z] INFO stderr         2> Stack:
[task 2020-03-30T17:52:43.534Z] INFO stderr         2> assertErrorMessage@/builds/worker/workspace/build/src/js/src/jit-test/lib/asserts.js:69:15
[task 2020-03-30T17:52:43.534Z] INFO stderr         2> @/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/comments.js:28:19
[task 2020-03-30T17:52:43.961Z] TEST-PASS | js/src/jit-test/tests/wasm/binary.js | Success (code 0, args "--ion-eager --ion-offthread-compile=off --more-compartments") [6.5 s]
[task 2020-03-30T17:52:44.152Z] /builds/worker/workspace/build/src/js/src/jit-test/lib/asserts.js:69:15 Error: Assertion failed: expected exception SyntaxError, no exception thrown
[task 2020-03-30T17:52:44.152Z] Stack:
[task 2020-03-30T17:52:44.152Z]   assertErrorMessage@/builds/worker/workspace/build/src/js/src/jit-test/lib/asserts.js:69:15
[task 2020-03-30T17:52:44.152Z]   @/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/comments.js:28:19
[task 2020-03-30T17:52:44.152Z] Exit code: 3
[task 2020-03-30T17:52:44.152Z] FAIL - wasm/comments.js
[task 2020-03-30T17:52:44.152Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/wasm/comments.js | /builds/worker/workspace/build/src/js/src/jit-test/lib/asserts.js:69:15 Error: Assertion failed: expected exception SyntaxError, no exception thrown (code 3, args "--ion-eager --ion-offthread-compile=off --more-compartments") [0.6 s]
[task 2020-03-30T17:52:44.153Z] INFO exit-status     : 3
[task 2020-03-30T17:52:44.153Z] INFO timed-out       : False
[task 2020-03-30T17:52:44.153Z] INFO stderr         2> /builds/worker/workspace/build/src/js/src/jit-test/lib/asserts.js:69:15 Error: Assertion failed: expected exception SyntaxError, no exception thrown
[task 2020-03-30T17:52:44.153Z] INFO stderr         2> Stack:
[task 2020-03-30T17:52:44.153Z] INFO stderr         2> assertErrorMessage@/builds/worker/workspace/build/src/js/src/jit-test/lib/asserts.js:69:15
[task 2020-03-30T17:52:44.153Z] INFO stderr         2> @/builds/worker/workspace/build/src/js/src/jit-test/tests/wasm/comments.js:28:19
Flags: needinfo?(lhansen)

Turns out wat 1.0.13 breaks a bunch of corner-case text format tests (bugs filed), and I had not run these tests before trying to land, sigh. Will await outcome of discussion of those issues before trying to re-land (with either a newer wat or with those test cases removed, though the latter seems unlikely).

Flags: needinfo?(lhansen)
Summary: Update wat crate to 1.0.13 → Update wat crate to 1.0.13 (actually probably 1.0.14)

Turns out that there are some bugs in 1.0.13 but also some changed error messages that are bugs in our tests technically, so waiting for 1.0.14 before doing a proper update.

Attachment #9136796 - Attachment description: Bug 1625660 - Update the wat crate to 1.0.13. r?rhunt → Bug 1625660 - Update the wat crate to 1.0.13. r=rhunt

Depends on D68815

1.0.14 is landing on bug 1624363.

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1624363
Attachment #9136796 - Attachment is obsolete: true
Attachment #9137743 - Attachment is obsolete: true
Attachment #9137742 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.