Closed Bug 1625726 Opened 1 year ago Closed 5 months ago

No sound on Dell XPS 2-in-1 9575

Categories

(Core :: Audio/Video: Playback, defect)

74 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1430907

People

(Reporter: soshial, Unassigned)

Details

(Whiteboard: [media-audio])

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

No steps needed to reproduce. No sound on Youtube or any other video hosting websites. Sound in other browsers work.

I would be happy to provide more info.

Versions:
Mozilla Firefox v74.0 for Windows
Windows 10 Home 1909
Realtek Audio driver version 10.0.18362.1

Actual results:

No sound.

Expected results:

Should be sound.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Could you please navigate to about:support and copy the information there onto this bug?

Flags: needinfo?(soshial)
Attached file about_support.txt
Flags: needinfo?(soshial)
  • Has sound ever worked in Firefox on this machine?
  • To be sure, you're expecting sound out of the Dell's speakers rather than another device, such as a headset?
  • Does the Window's volume mixer show any output for Firefox when playing videos (the one you get from right clicking the speaker icon on the taskbar -> Open Volume mixer)?
Flags: needinfo?(soshial)
  • Yes, sound works normally in all other programs on my machine. In Firefox it mostly doesn't work. othertimes it suddenly works.
  • Yes, I am expecting sound from Dell speakers.
  • When the sound in Firefox disappears Windows, volume mixer shows output and that sound is on. I can even change the sound output device, but there still is no sound.
Flags: needinfo?(soshial)

The sound sometimes works? Do you have any sense of what's different in those cases? Different devices connected? Following a restart?

Can you open Windows 'Sound Mixer Options', which allows for setting app specific output devices, and check that Firefox is using the default device?

Flags: needinfo?(soshial)
Whiteboard: [media-audio]

Exactly, the sound sometimes does work. My devices are A) default Realtek audio output and B) Bluetooth speaker. The problem happens to both of them. I am trying to find some pattern to this, but it is not quite obvious. I restart computer quite often and there is no difference with sound problem even after restart.

I checked the "Sound Mixer options", Firefox is always using default devices. But there is a strange thing – for every Firefox tab that has sound, the Sound Mixer creates separate Firefox setting row. I've just had this scenario:

  1. one Firefox tab with Youtube had sound, another tab didn't have any sound
  2. The video was the same, volume was maximum on both of them
  3. Sound Mixer had 2 identical Firefox settings rows
Flags: needinfo?(soshial)

The priority flag is not set for this bug.
:bryce, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(bvandyk)

If a page doesn't have sound, does closing and reopening that tab ever fix it?

If you only open one tab in the browser, is it seemingly random if it has sound or not?

Could you test if the same issue happens in Firefox nightly?

:kinetik, this sounds like we may be failing to open streams? Do you have any thoughts? Any logs you think could help here?

Flags: needinfo?(bvandyk) → needinfo?(kinetik)

Unrelated to the core issue here, but the issue with extra Firefox entries appearing in the volume mixer is resolved in Firefox 76 by bug 1430907 and changes before that.

In the comment 9 screenshot, note that all of the Firefox audio streams are muted (the speaker icon to the left of the slider shows the muted speaker icon 🔇). It doesn't seem like the new "Sound Mixer" UI allows you unmute by clicking the speaker icons directly, either. If you open the old "Volume Mixer" UI (right click the speaker icon in the desktop notification area then select "Open Volume mixer"), you can unmute any Firefox entries by clicking the speaker icon below the volume slider for that entry. Alternatively, trying "Reset to the Microsoft recommended defaults" in the new "Sound Mixer" UI should reset all app audio settings (including mute) to the default.

Flags: needinfo?(kinetik) → needinfo?(soshial)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Severity: normal → S3

The severity of these bugs was changed, mistakenly, from normal to S3.

Because these bugs have a priority of --, indicating that they have not been previously triaged, these bugs should be changed to Severity of --.

Severity: S3 → --
Severity: -- → S3

After the bug 1430907 was fixed, my issue was resolved.

Flags: needinfo?(soshial)
Status: UNCONFIRMED → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1430907

(In reply to soshial from comment #16)

After the bug 1430907 was fixed, my issue was resolved.

Thanks for letting us know.

You need to log in before you can comment on or make changes to this bug.