[FIX]Button elements do not align correctly vertically

RESOLVED FIXED in mozilla1.2beta

Status

()

Core
Layout: Form Controls
P3
major
RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: Jostein Huglen, Assigned: bz)

Tracking

Trunk
mozilla1.2beta
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Button elements do not align vertically along the baseline of other text etc.

Let Mozilla render this:

<p>Test text <button>Button</button> <input type="submit" /> some more text.</p>

... and notice how the button element is not correctly aligned vertically,
unlike the input element.

This bug makes the use of button elements look very weird in Mozilla...
(Reporter)

Updated

16 years ago
Target Milestone: --- → mozilla1.1final
(Reporter)

Comment 1

16 years ago
This bug was previously reported as bug 58190, and was marked fixed in 2001.

I'm still seeing this bug however, both in Mozilla 1.0 and Mozilla build 2002081308.

I was hoping this bug could be fixed before Mozilla 1.1 gets released, since
it's afterall making Mozilla render basic HTML 4 incorrectly. I'd do it myself,
if I only had the expertise...
(Reporter)

Updated

16 years ago
Priority: -- → P1
Not happening for 1.1 unless it's a crash fix, at this point.
Assignee: rods → bzbarsky
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: P1 → P3
Target Milestone: mozilla1.1final → mozilla1.2alpha
Neither are truly baseline-to-baseline-aligned -- it's just the input is
'text-bottom' aligned, but the button is 'baseline' aligned and the baseline
knowledge doesn't to through the button.  The following patch would make the
bottoms of the controls line up, but they'll still be different sizes.
Created attachment 95273 [details] [diff] [review]
make things a little more consistent
Comment on attachment 95273 [details] [diff] [review]
make things a little more consistent

r=bzbarsky.  The size issues will require lots of work (this is where I mention
XBL form controls and put the work off).
Attachment #95273 - Flags: review+
Comment on attachment 95273 [details] [diff] [review]
make things a little more consistent

sr=roc+moz
Attachment #95273 - Flags: superreview+
missed alpha deadline.. will try to land in beta.
Summary: Button elements do not align correctly vertically → [FIX]Button elements do not align correctly vertically
Target Milestone: mozilla1.2alpha → mozilla1.2beta
*** Bug 126813 has been marked as a duplicate of this bug. ***
marking fixed; size issues live in bug 70251 and its dependencies already.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.