Closed Bug 1625836 Opened 7 months ago Closed 7 months ago

Crash in [@ InvalidArrayIndex_CRASH | mozilla::layers::DisplayItemCache::CanReuseItem]

Categories

(Core :: Graphics: WebRender, defect)

Unspecified
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1624125

People

(Reporter: gsvelto, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-adafa609-03c4-437d-9624-1b84a0200327.

Top 10 frames of crashing thread:

0 libxul.so InvalidArrayIndex_CRASH xpcom/ds/nsTArray.cpp:27
1 libxul.so mozilla::layers::DisplayItemCache::CanReuseItem gfx/layers/wr/DisplayItemCache.cpp:126
2 libxul.so mozilla::wr::DisplayListBuilder::ReuseItem gfx/webrender_bindings/WebRenderAPI.cpp:1521
3 libxul.so mozilla::layers::WebRenderCommandBuilder::CreateWebRenderCommands gfx/layers/wr/WebRenderCommandBuilder.cpp:1673
4 libxul.so mozilla::layers::WebRenderCommandBuilder::CreateWebRenderCommandsFromDisplayList gfx/layers/wr/WebRenderCommandBuilder.cpp:1793
5 libxul.so nsDisplayTransform::CreateWebRenderCommands layout/painting/nsDisplayList.cpp:8620
6 libxul.so mozilla::layers::WebRenderCommandBuilder::CreateWebRenderCommands gfx/layers/wr/WebRenderCommandBuilder.cpp:1684
7 libxul.so mozilla::layers::WebRenderCommandBuilder::CreateWebRenderCommandsFromDisplayList gfx/layers/wr/WebRenderCommandBuilder.cpp:1793
8 libxul.so nsDisplayTransform::CreateWebRenderCommands layout/painting/nsDisplayList.cpp:8620
9 libxul.so mozilla::layers::WebRenderCommandBuilder::CreateWebRenderCommands gfx/layers/wr/WebRenderCommandBuilder.cpp:1684

New crash first happening in buildid 20200322212426, seen across all platforms. The raw crash reasons for the four crashes we have on file are:

ElementAt(aIndex = 1512, aLength = 1024)
ElementAt(aIndex = 1024, aLength = 1024) 
ElementAt(aIndex = 1025, aLength = 1024) 
ElementAt(aIndex = 1555, aLength = 1024) 

I believe that this is a variant of bug 1624125.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1624125
You need to log in before you can comment on or make changes to this bug.