Closed Bug 1625882 Opened 3 years ago Closed 2 years ago

Firefox does not synchronously update its surface on resize

Categories

(Core :: Widget: Gtk, defect)

74 Branch
Desktop
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1608617

People

(Reporter: bjoern.daase, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:74.0) Gecko/20100101 Firefox/74.0

Steps to reproduce:

This was raised in https://gitlab.gnome.org/GNOME/mutter/-/issues/977#note_752470 and Robert said, there is no Firefox bug yet. So here you go.

It affects (at least) Firefox 74 in combination with mutter 3.36:
You always get a one frame glitch occasionally visible when using tiling (super+up|down|left|right) or when unfullscreening a video. This has most likely to do with Firefox not synchronously updating it surface on resize (original problem is here: https://bugzilla.mozilla.org/show_bug.cgi?id=1609538#c7).

Actual results:

A one frame glitch where Firefox is rendered fullscreen when it should be windowed.

Expected results:

No glitches.

Please use Widget Gtk and make it block bug 635134 - that should get Martin involved.

Blocks: wayland
Component: Layout: Images, Video, and HTML Frames → Widget: Gtk
OS: Unspecified → Linux
Hardware: Unspecified → Desktop

Can you create a screencast (video) of the issue?
Thanks.

Flags: needinfo?(bjoern.daase)
Flags: needinfo?(bjoern.daase)

There you go. It is a bit hard to see because it is only one frame (especially the glitch when resizing) but the (un-)fullscreen glitch is actually quite visible in the screencast.

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Because this bug's Severity has not been changed from the default since it was filed, and it's Priority is -- (Backlog,) indicating it has has not been previously triaged, the bug's Severity is being updated to -- (default, untriaged.)

Severity: normal → S3

The severity of these bugs was changed, mistakenly, from normal to S3.

Because these bugs have a priority of --, indicating that they have not been previously triaged, these bugs should be changed to Severity of --.

Severity: S3 → --

This is actually a duplicate of bug 1608617

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1608617
You need to log in before you can comment on or make changes to this bug.