Closed Bug 1625906 Opened 3 months ago Closed 3 months ago

Show dedicated warning to users trying to connect to Firefox for Android

Categories

(DevTools :: about:debugging, enhancement, P2)

enhancement

Tracking

(firefox76 fixed)

RESOLVED FIXED
Firefox 76
Tracking Status
firefox76 --- fixed

People

(Reporter: jdescottes, Assigned: jdescottes)

References

Details

(Keywords: dev-doc-complete)

Attachments

(3 files)

For remote debugging, our backward compatibility policy only supports debugging servers at most 2 versions older than the client. This means that ESR68 can be debugged from Firefox 68, 69 or 70. Therefore you have to use Firefox Desktop ESR68 in order to connect to Fennec (https://www.mozilla.org/en-US/firefox/all/#product-desktop-esr).

Firefox Preview should have been rolled out instead of Firefox for Android, but since this is delayed, we should improve the onboarding for users trying to debug Firefox for Android from the current Firefox desktop.

We can't make remote debugging work, but we can at least show a message that explains the situation and guides the user to:

  • download ESR68
  • enable the new about:debugging

download ESR68

While profile data-loss is prevented by version checks, Firefox ESR will replace the current installed Firefox if the user doesn't take extra care.

Another option to consider is to point developers to Firefox Nightly (aka "Firefox Nightly for Developers (Early Access)"). It would not help them to reproduce Fennec-specific issues, so this assumes that the general use case is "I want to test on Firefox for Android". It would help with the migration of developers to the future proof version.

(In reply to :Harald Kirschner :digitarald from comment #1)

download ESR68

While profile data-loss is prevented by version checks, Firefox ESR will replace the current installed Firefox if the user doesn't take extra care.

I think the message in about:debugging should be short and link to an MDN page where we could explain all the necessary steps to start Firefox ESR with a different profile.

Another option to consider is to point developers to Firefox Nightly (aka "Firefox Nightly for Developers (Early Access)"). It would not help them to reproduce Fennec-specific issues, so this assumes that the general use case is "I want to test on Firefox for Android". It would help with the migration of developers to the future proof version.

Yes it should also be part of the message. Personally, I've always preferred to test against the browsers widely available, even for new feature development.

Depends on D69003

This backward compatibility message was only relevant for Firefox 67.
We can remove it.

Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5c0e83eb5f61
Add dedicated warning message for users trying to debug firefox for android 68 r=Harald,daisuke,fluent-reviewers,flod
https://hg.mozilla.org/integration/autoland/rev/c0767b7385e6
Remove backward compatibility message dedicated to debugger regression for Firefox 67 r=daisuke,fluent-reviewers
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 76
Keywords: dev-doc-needed

For this bug we would need to add a section to https://developer.mozilla.org/en-US/docs/Tools/about:debugging that explains how to debug Firefox for Android from the current Firefox Desktop.

This warning message will start appearing in about:debugging with Firefox 76, if you connect to Firefox for Android (release channel).

The message displayed in about:debugging is:

This version of Firefox cannot debug Firefox for Android (68). 
We recommend installing Firefox for Android Nightly on your phone for testing. More details

"More details" is a link that points to https://developer.mozilla.org/en-US/docs/Tools/about:debugging#Connection_to_Firefox_for_Android_68 (the anchor doesn't match anything for now, the idea is to add a section on the page that matches it.

The issue with Firefox for Android is that the main release of Firefox for Android (also known as Fennec) is based on Firefox 68, and this is too old to be debugged by the current Firefox Desktop.

From a product perspective, we would like users to try to test against Firefox for Android Nightly, which is following the same release cycle as Firefox Nightly. But there is a catch here: users MUST use Firefox Nightly on Desktop to connect as well. So we should make that clear. (I overlooked this issue when I agreed to suggest only Firefox for Android Nightly in the message...). They could also download the release channel of Firefox Preview to connect from the release channel of Firefox Desktop.

The other option, if users need to test against Firefox for Android release, is to download Firefox 68 ESR and either:

  • use WebIDE
  • or go to about:config to set devtools.aboutdebugging.new-enabled to true and use about:debugging

I will add a "draft" version of the section for MDN below to get things started.

(draft for MDN)

Connection to Firefox for Android 68

The current release of Firefox for Android cannot be debugged from the main releases of Firefox Desktop. After connecting to Firefox for Android release, you will see the following message in the runtime page:

[insert image of the message]

(Note: the message is only displayed on Firefox 76 or newer, older versions will show a more generic message but the issue remains the same)

Firefox for Android release is currently based on Firefox 68, which is too old to be debugged by Firefox Desktop. In the future it will be replaced by a new Firefox for Android application, which will be released in sync with Firefox Desktop.

In the meantime, to debug Firefox for Android, you should use:

If you prefer to test Firefox for Android release, you can still download Firefox 68 ESR for Desktop. Note that about:debugging is not enabled by default on this version of Firefox. To enable it, you need to go about:config and set devtools.aboutdebugging.new-enabled to true. To avoid profile corruptions, you will have to create a separate profile to use Firefox 68 ESR. More information at https://support.mozilla.org/kb/dedicated-profiles-firefox-installation#w_what-happens-to-my-profile-if-i-downgrade-to-a-previous-version-of-firefox

[1] Not part of the draft: this is the good link right? Firefox for Android Nightly users have been migrated to Firefox Preview Nightly, but the store page still mentions Firefox Preview? I was expecting the labeling to be updated?

Janet: hi! See #comment 7 for some more context, but it would be great to add a new section to the about:debugging MDN page. I tried to provide context in comment 7 and a draft in comment 8. Let me know if I should rather open a bug on GitHub.

Harald: quick ping in case you want to review the draft and give pointers to shape the messaging differently. Also I think we shouldn't have explicitly said Firefox for Android Nightly in our error message, since this would only work for users on Firefox Nightly desktop. Want me to file a follow up to update the message?

Flags: needinfo?(jswisher)
Flags: needinfo?(hkirschner)

Julian, thanks for flagging this. We're tracking it here in GitHub.

Also, any idea if/when Fx for Android will be updated such that this section will not be necessary? I want to make sure we have an issue to update or remove it so it doesn't become stale/obsolete.

Flags: needinfo?(jswisher) → needinfo?(jdescottes)

I've added the new section.

There was already a note about version disparities under Connecting to a remote device, so I put the info about the error message there. If you get to the new section by clicking "More details", you've already seen the error message.

Julian, please review and let me know if I need to change anything.

Also, any idea if/when Fx for Android will be updated such that this section will not be necessary?

So far we don't have an update on that. We make sure to block a bug to update the warning when we have launch details.

Flags: needinfo?(jdescottes)
Flags: needinfo?(hkirschner)

Forgot this comment as I ticked this off my todo list after reviewing the remote debugging message :/

Harald: quick ping in case you want to review the draft and give pointers to shape the messaging differently. Also I think we shouldn't have explicitly said Firefox for Android Nightly in our error message, since this would only work for users on Firefox Nightly desktop. Want me to file a follow up to update the message?

The MDN draft nails it, thanks a lot for taking the lead on this Julian!

The link looks good and I am also not sure why nothing else on the product page upgraded. It might be part of the staged rollout, to make sure we can keep users on the old version for comparison. I will double-check async with the mobile team.

(In reply to Janet Swisher from comment #13)

I've added the new section.

There was already a note about version disparities under Connecting to a remote device, so I put the info about the error message there.

Julian, please review and let me know if I need to change anything.

That looks great! Thanks Janet.

If you get to the new section by clicking "More details", you've already seen the error message.

Indeed that's a good point! My only nit would be about the message just above the image: In Firefox 76 and above, the message looks like the following:. With Firefox 76, you can still get the "regular" warning message, if you try to connect to a browser which is too old but which is not Firefox for Android 68. Maybe the message should be more hypothetical, eg In Firefox 76 and above, the message can look like the following:

You need to log in before you can comment on or make changes to this bug.