Unlike IE and Netscape 4.7, the Mozilla history file isn't up to date after a Mozilla crash

RESOLVED DUPLICATE of bug 63292

Status

defect
RESOLVED DUPLICATE of bug 63292
17 years ago
10 months ago

People

(Reporter: samlew_lksk, Assigned: radha)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
I recently entered another bug, where Mozilla would crash after opening up
several tabbed windows from a local news site. I went through several Mozilla
crashes in one day.

It was after the crashes that I realized that both IE and Netscape seem to
update their on disk history files quite often, possibly as you're surfing.
However, it seems Mozilla doesn't update the history file as often, or at least
it updates the history file in a manner where all the most recent entries aren't
preserved on disk. The result is that after a crash, all the urls of the  web
pages you had visited just prior to the crash were lost. 

It never occurred to me that, while Netscape 4.75 crashed a lot (hence my moving
to  Mozilla), the damage actually was quite slight. I could just go back to the
history file and see where I had been. However, with Mozilla, while having a lot
of web pages open with the tabbed windows is quite convenient which means you
tend of have a lot of windows open. But if a crash occurs, it's much more
painful than Netscape or IE since you can't retrace your surfing steps.

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 63292 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Component: History: Session → History: Global
Resolution: --- → DUPLICATE

Updated

10 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.