Closed Bug 1627047 Opened 10 months ago Closed 10 months ago

Remove uses of FunctionBox::function() in ParseContext

Categories

(Core :: JavaScript Engine, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: mgaudet, Assigned: mgaudet)

References

Details

Attachments

(3 files)

No description provided.
Summary: Determine if `this` binding is required without JSFunction in ParseContext → Remove uses of FunctionBox::function() in ParseContext
Assignee: nobody → mgaudet
Status: NEW → ASSIGNED
Priority: -- → P1
Pushed by mgaudet@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/44cd69be9c8d
Initialize FunctionBox from lazy function by absorbing flags r=caroline
https://hg.mozilla.org/integration/autoland/rev/a5dbb15d598d
Use FunctionBox to answer if we have thisBinding r=caroline
https://hg.mozilla.org/integration/autoland/rev/a930692de996
Use FunctionBox to declare arguments object r=caroline
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
Duplicate of this bug: 1588133
You need to log in before you can comment on or make changes to this bug.