Closed Bug 1627108 Opened 2 years ago Closed 2 years ago

Worker threads are accidentally selected at startup

Categories

(DevTools :: Framework, defect, P1)

defect

Tracking

(Fission Milestone:M6c, firefox77 verified)

VERIFIED FIXED
Firefox 77
Fission Milestone M6c
Tracking Status
firefox77 --- verified

People

(Reporter: jlast, Assigned: jlast)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-fission-m2-mvp)

Attachments

(1 file, 1 obsolete file)

STR

  1. Open the browser toolbox
  2. open the debugger in the content toolbox

ER: the main thread should be selected
AR: the parser-worker thread is selected

The reason for this is that when workers startup they momentarily pause and issue an attached event, which selects the thread. We should just ignore this event.

Assignee: nobody → jlaster
Status: NEW → ASSIGNED
Priority: -- → P1
Whiteboard: dt-fission-m2-mvp
Attachment #9138620 - Attachment is obsolete: true
Pushed by jlaster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/47378ab982b4
Worker threads are accidentally selected at startup. r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77
Flags: qe-verify+

Tracking dt-fission-m2-mvp bugs for Fission Nightly milestone (M6c)

Fission Milestone: --- → M6c

Reproduced the initial issue using an old Nightly from 2020-04-02, verified that using latest Nightly 78.0a1 and Nightly 77.0a1 before the fix this is no longer an issue, across platforms (Windows 10 64bit, macOS 10.15.5 beta 3 and Ubuntu 18.04 64bit).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.