Closed Bug 1627441 Opened 3 years ago Closed 3 years ago

Maximising window not moving to top & filling screen

Categories

(Core :: Widget: Gtk, defect, P3)

74 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1609538

People

(Reporter: david.swarbrick9, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/80.0.3987.163 Safari/537.36

Steps to reproduce:

Open firefox, use super + up arrow to maximise window

Running Firefox 74.0.1 on Arch Linux under Wayland using the Mutter window manager.

Actual results:

The top/title bar stretches across the viewable screen, but extends off the screen (shown in screenshot)

Expected results:

the window should move to the top of the current workspace, and fill only the visible screen

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Blocks: wayland
Priority: -- → P3

Most likely another dup of bug 1609538 - David, mind testing beta or nightly? (or just wait for 75 - it will be released tomorrow :) )

Flags: needinfo?(david.swarbrick9)

Just tested Nightly (76.0a1 (2020-04-06) (64-bit)) and the issue is resolved, thank you!
Apologies that I didn't spot the other bug before filing.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(david.swarbrick9)
Resolution: --- → DUPLICATE
Duplicate of bug: 1609538
You need to log in before you can comment on or make changes to this bug.