Closed Bug 1628081 Opened 1 year ago Closed 1 year ago

New behaviour of url bar on Linux is broken. Now it's hard to copy the address to clipboard, it takes at least 3 clicks to select the entire address.

Categories

(Firefox :: Address Bar, defect)

75 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 333714

People

(Reporter: martin.tk, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

Click the address in url bar

Actual results:

The address is selected but not copied to the clipboard

Expected results:

The address should be copied to the clipboard. It used to be possible to achieve this in previous version by double clicking the address. Now it takes many more clicks to actually select the entire address so it gets copied to clipboard. In the process, the clipboard is polluted with fragments of the address after unsuccessful selection of the entire url

Component: Untriaged → Address Bar

to copy to the primary clipboard you must triple-click the field, triple-click is a common action to Select All in input fields. There is a rel-note about that.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 333714

(In reply to Marco Bonardo [:mak] from comment #1)

to copy to the primary clipboard you must triple-click the field, triple-click is a common action to Select All in input fields. There is a rel-note about that.

*** This bug has been marked as a duplicate of bug 333714 ***

This is terrible. Initial click it completely pointless. Needlessly selects the contents making both editing and copying the url harder.

Making the user triple click instead of double click is just making the application worse. What's the point?

At least make it possible for the user to return to previous behaviour via preference.

This makes the new version of Firefox worse than the previous one. Very disappointing.

You need to log in before you can comment on or make changes to this bug.