Closed Bug 1628203 Opened 2 years ago Closed 2 years ago

H264 videos are laggy in Firefox Flatpak

Categories

(Core :: Audio/Video: Playback, defect)

75 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1628428

People

(Reporter: pizzadudedotca, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

H264 videos are laggy in Firefox Flatpak from flathub.

Steps to reproduce:

  1. Go to a website with h264 videos, or download h264ify addon and watch youtube videos
  2. Notice videos are laggy

Actual results:

The videos are laggy.

Expected results:

The videos should play back smoothly.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Mozilla/5.0 (X11; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0
Linux 5.5.15-200.fc31.x86_64

I am having the exact same issue.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1628428

I was having the same issues, and running the commands below fixed them:

flatpak install flathub org.freedesktop.Platform/x86_64/19.08
flatpak install flathub org.freedesktop.Platform.openh264/x86_64/19.08

I have both org.freedesktop.Platform/x86_64/19.08 and org.freedesktop.Platform.openh264/x86_64/19.08 installed. I am now on F76 and still am having choppy h264 video. Worth noting that I am running wayland not x11 but I have tested it with both the wayland overrides on/off and both modes have the choppy h264 video.

I have the same problem under GNOME Wayland and I have the "19.08" flatpaks installed.

I have the same problem under Manjaro KDE Plasma, X11. Normal Firefox works fine, Flatpak Firefox gives me laggy videos. Haven't had the problem with youtube.com, but for the videos on nrk.no which is the biggest TV broadcaster in my country, it's really laggy. The visuals tend to lag more than the audio.

You need to install ffmpeg-full:
flatpak install flathub org.freedesktop.Platform.ffmpeg-full

and then check that you have:
[Org.freedesktop.Platform.ffmpeg-full extension]
directory = lib/ffmpeg
add-ld-path =.
no-autodownload = true
version = 19.08

in /var/lib/flatpak/app/org.mozilla.firefox/current/active/metadata

(In reply to Radio Pulsar from comment #8)

You need to install ffmpeg-full:
flatpak install flathub org.freedesktop.Platform.ffmpeg-full

and then check that you have:
[Org.freedesktop.Platform.ffmpeg-full extension]
directory = lib/ffmpeg
add-ld-path =.
no-autodownload = true
version = 19.08

in /var/lib/flatpak/app/org.mozilla.firefox/current/active/metadata

This worked BUT be sure when flatpak asks you about what version of ffmpeg-full to install to choose 19.08 or it won't work. I also installed the ffmpeg-extension because it wasn't installed.

(In reply to mozilla38 from comment #9)

(In reply to Radio Pulsar from comment #8)

You need to install ffmpeg-full:
flatpak install flathub org.freedesktop.Platform.ffmpeg-full

and then check that you have:
[Org.freedesktop.Platform.ffmpeg-full extension]
directory = lib/ffmpeg
add-ld-path =.
no-autodownload = true
version = 19.08

in /var/lib/flatpak/app/org.mozilla.firefox/current/active/metadata

This worked BUT be sure when flatpak asks you about what version of ffmpeg-full to install to choose 19.08 or it won't work. I also installed the ffmpeg-extension because it wasn't installed.

My firefox metadata file (/var/lib/flatpak/app/org.mozilla.firefox/current/active/metadata) contained the following section (note 20.08 in the version):

[Extension org.freedesktop.Platform.ffmpeg-full]
directory=lib/ffmpeg
add-ld-path=.
no-autodownload=true
version=20.08

Without touching that file, I just installed the 20.08 version of ffmpeg-full, restarted firefox, and voilla -- it worked again! I also ONLY seemed to have problems with laggy videos on NRK.no.

$ flatpak install runtime/org.freedesktop.Platform.ffmpeg-full/x86_64/20.08
You need to log in before you can comment on or make changes to this bug.