Closed Bug 1628412 Opened 10 months ago Closed 9 months ago

Find does not work in debugQA's text editor

Categories

(SeaMonkey :: Find In Page, defect)

defect
Not set
normal

Tracking

(seamonkey2.53 affected, seamonkey2.57esr affected)

RESOLVED FIXED
seamonkey 2.74
Tracking Status
seamonkey2.53 --- affected
seamonkey2.57esr --- affected

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

Details

(Whiteboard: SM2.53.3)

Attachments

(1 file)

If you select Edit->Find in debugQA's Text Editor nothing happens and you get some messages in the error console:
Timestamp: 4/8/20, 5:33:19 PM GMT+1
Error: TypeError: document.getElementById(...) is null
Source File: chrome://editor/content/ComposerCommands.js
Line: 2290
Timestamp: 4/8/20, 5:33:19 PM GMT+1
Error: An error occurred executing the cmd_find command: [Exception... "[JavaScript Error: "document.getElementById(...) is null" {file: "chrome://editor/content/ComposerCommands.js" line: 2290}]'[JavaScript Error: "document.getElementById(...) is null" {file: "chrome://editor/content/ComposerCommands.js" line: 2290}]' when calling method: [nsIControllerCommand::doCommand]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: chrome://global/content/globalOverlay.js :: goDoCommand :: line 93" data: yes]
Source File: chrome://global/content/globalOverlay.js
Line: 95

[Approval Request Comment]
Regression caused by (bug #): unknown
User impact if declined: cannot use find in text editor
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #9139227 - Flags: review?(frgrahl)
Attachment #9139227 - Flags: approval-comm-release?
Attachment #9139227 - Flags: approval-comm-esr60?
Comment on attachment 9139227 [details] [diff] [review]
Fix find in Text Editor

LGTM
Attachment #9139227 - Flags: review?(frgrahl)
Attachment #9139227 - Flags: review+
Attachment #9139227 - Flags: approval-comm-release?
Attachment #9139227 - Flags: approval-comm-release+
Attachment #9139227 - Flags: approval-comm-esr60?
Attachment #9139227 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/e7b674413abc
Find does not work in debugQA's text editor. r=frg DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.74
Whiteboard: SM2.53.3
You need to log in before you can comment on or make changes to this bug.