Closed Bug 1628873 Opened 4 months ago Closed 3 months ago

Merge EditorSmileyOverlay into EditorOverlay

Categories

(SeaMonkey :: Composer, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

(Whiteboard: SM2.53.3)

Attachments

(1 file)

There's no point in EditorSmileyOverlay being in a separate overlay, it might as well be part of EditorOverlay. It is currently only used in messengercomposer but, once formatting bar is customisable, could be used in composer too.

Depends on: 606683

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: none
Testing completed (on m-c, etc.): 2.53.2
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

editorSmileyOverlay.dtd could be merged into editorOverlay.dtd at a later date if required.

Attachment #9139600 - Flags: review?(frgrahl)
Attachment #9139600 - Flags: approval-comm-release?
Attachment #9139600 - Flags: approval-comm-esr60?
Comment on attachment 9139600 [details] [diff] [review]
Merge editorSmileyOverlay

LGTM
Attachment #9139600 - Flags: review?(frgrahl)
Attachment #9139600 - Flags: review+
Attachment #9139600 - Flags: approval-comm-release?
Attachment #9139600 - Flags: approval-comm-release+
Attachment #9139600 - Flags: approval-comm-esr60?
Attachment #9139600 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/4fc9cddb1ded
Merge EditorSmileyOverlay into EditorOverlay. r=frg DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Whiteboard: SM2.53.3
You need to log in before you can comment on or make changes to this bug.