Closed Bug 1628903 Opened 3 months ago Closed 1 month ago

Evaluate performance of Read Ahead DLL prefetches

Categories

(Core :: Widget: Win32, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: emalysz, Assigned: emalysz)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fxperf:p2])

Attachments

(2 files, 1 obsolete file)

Attached file Logfile.CSV.zip

We prefetch a few DLLs on startup (like ExplorerFrame.dll). We should reevaluate our usage of ReadAheadDlls_ThreadStart to see if this is necessary, since the files are eventually read by a content process later in startup.

The Windows Procmon log for the build (https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/NhgxSmL5TkyNErk72PCbMw/runs/0/artifacts/public/build/target.zip) is attached.

Blocks: 1627071
Summary: Evaluate performance of DLL prefetches → Evaluate performance of Read Ahead DLL prefetches

Here are DLLs and libraries that we have identified as candidates for investigating prefetch: explorerFrame.dll, d3d9.dll, libegl.dll, dwrite.dll, d3dcompiler.dll, nssckibi.dll, cach2 dlls, freebl3.dll, softokn3.dll, firefox.exe

Blocks: 1631884
No longer blocks: 1631884
Whiteboard: [fxperf]
See Also: → 1538279
Whiteboard: [fxperf] → [fxperf:p2]
Assignee: nobody → emalysz
Duplicate of this bug: 1627099
Attachment #9144424 - Attachment description: Bug 1628903: testing only - prefetch DLLs that were identified as good candidates → Bug 1628903: Prefetch DLLs to improve disk reads on Windows HDD devices.
Pushed by nerli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6c10970490f3
Prefetch DLLs to improve disk reads on Windows HDD devices. r=aklotz
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
See Also: → 1640243
See Also: → 1640087
Attachment #9144416 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.