Closed Bug 1629030 Opened 3 months ago Closed 1 month ago

[Reader View] Changing the line height while the page is scrolled down hides the dropdown

Categories

(Toolkit :: Reader Mode, defect, P5)

defect

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox-esr68 --- wontfix
firefox75 --- wontfix
firefox76 --- wontfix
firefox77 --- wontfix
firefox78 --- verified

People

(Reporter: oana.botisan, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

Attached image reader view.gif

Affected versions

  • Firefox 75.0
  • Firefox 76.0b3
  • Firefox 77.0a1

Affected platforms

  • Windows 10 x64
  • macOS 10.15
  • Ubuntu 18.04 x64

Steps to reproduce

  1. Go to https://en.wikipedia.org/wiki/Main_Page.
  2. Click on Toggle reader view.
  3. Scroll down the page.
  4. Click on the Type controls button from the Reader View sidebar.
  5. Click on the Decrease/Increase Line Height.

Expected result

  • The Type Control menu stays opened.

Actual result

  • The Type Control menu closes after one click.

Regression range

Additional notes

  • Please look at the attached gif.
  • This issue is reproducing only when you scroll down the page.

I think the patch in bug 1550836 might fix this.

Note that in both the gif and my testing, the line height still changes - but the dropdown is hidden immediately.

Priority: -- → P5
See Also: → 1550836
Summary: [Reader View] Can't change the line height while the page is scrolled down → [Reader View] Changing the line height while the page is scrolled down hides the dropdown

The steps from comment #0 still reproduce the issue for me in Nightly build ID 20200513094918 which has the change from bug 1550836.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Regressed by: 1507279

The fact that CSS set a fixed line-height on an inner element meant that the
main body of the reader mode text was not changing line height based on the CSS
variable we set on a container higher in the DOM hierarchy.

This problem only happens if you're scrolled down on the page and then change
font configuration settings (like line height or font size) that cause the
scroll position to change. The scroll event fires and we hide popups in
response. To fix this, we keep a cached height of the body, so that if the
page height has changed since the last scroll event, we don't immediately close
the popup.

Depends on D76310

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/82160fd55e1f
make line height changes actually take effect in reader mode, r=jaws
https://hg.mozilla.org/integration/autoland/rev/63a158b481ea
don't close an open popup when the font changes in reader mode (due to spurious scroll events), r=jaws
https://hg.mozilla.org/integration/autoland/rev/ae43921b1fe6
remove obsolete android code from reader mode, r=jaws
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Flags: qe-verify+

Reproduced the issue using Firefox 77.0a1 (20200410213700) on Windows 10.x64.
The issue is verified fixed with Firefox 78.0b7 (20200612174529) on Windows 10x64, macOS 10.12 and Ubuntu 18.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.