Closed Bug 1629106 Opened 8 months ago Closed 8 months ago

Implement Logical Assignment Operators proposal

Categories

(Core :: JavaScript Engine, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: anba, Assigned: anba)

References

(Blocks 1 open bug, )

Details

(Keywords: dev-doc-complete)

Attachments

(2 files)

Depends on: 1629792

Restricted to Nightly because there's still an open issue about inferred
function names and because the proposal was only recently moved to stage 3.

Depends on D70821

Hi Christian,
just wanted to give you a heads-up that this bug will add three new compound assignment operators (&&=, ||=, and ??=) to JS. The changes are currently restricted to Nightly builds, because the proposal only just recently reached stage 3.

Thanks,
André

Flags: needinfo?(choller)

Thanks for the heads-up! I will run the parser target on this for extensive testing once it has landed.

Flags: needinfo?(choller)
Priority: -- → P2
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/17566bf1e9cd
Part 1: Implement Logical Assignment Operators proposal. r=yulia
https://hg.mozilla.org/integration/autoland/rev/373440004686
Part 2: Enable test262 tests for Logical Assignment Operators proposal. r=yulia
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
No longer regressions: 1634780
You need to log in before you can comment on or make changes to this bug.