Closed Bug 1629303 Opened 4 years ago Closed 4 years ago

Megabar expanding/shrinking issue and epilepsy

Categories

(Firefox :: Address Bar, defect, P2)

75 Branch
defect
Points:
5

Tracking

()

RESOLVED FIXED
Firefox 79
Iteration:
79.1 - June 1 - June 14
Accessibility Severity s3
Tracking Status
firefox-esr68 --- unaffected
firefox77 --- wontfix
firefox78 --- fixed
firefox79 --- fixed

People

(Reporter: jandatroy, Assigned: bugzilla)

References

(Blocks 3 open bugs)

Details

(Keywords: access, losing-users)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

update to the new Firefox 75 version
use the address bar

Actual results:

the expanding and shrinking of the address bar has caused triggers with my epilepsy. the sudden expanding and then when moving away from the address bar has a similar effect as a strobe light and has triggerd mild symptoms of epilepsy such as losing focus, feeling mildly dizzy, and eye studdering (eye movements like little jerks)

I want to make a point that these are mild reaction and although I don't end up on the floor having an epileptic seizure, the effects to cause stress and triggers which could lead to that end result

Expected results:

Disabling the new function the issues cease to happen.

Component: Untriaged → Address Bar
Keywords: access

Have you set your OS to reduced motion? The addressbar should respect that setting. Other than that, when you focus the addressbar there's a pop-up (user initiated, like any other menu or pop-up) that seems to be causing you issues. How do you deal with menus popping up or select widgets or other items that pop up on user activation? Note, we're probably going to include a preference for not popping up on focus.

(In reply to Asa Dotzler [:asa] from comment #1)

Have you set your OS to reduced motion? The addressbar should respect that setting. Other than that, when you focus the addressbar there's a pop-up (user initiated, like any other menu or pop-up) that seems to be causing you issues. How do you deal with menus popping up or select widgets or other items that pop up on user activation? Note, we're probably going to include a preference for not popping up on focus.

I don't use widgets and employ a popup blocker I try to limit animations from within Firefox and also disable windows animations in Windows 10. I keep Firefox open maximized. I open new links in tabs and wait for the tab to load before switching to it. To limit sudden movements I generally type out urls or ctrl-c/ctrl-v when ever possible. I also take medication that helps to a point. But as someone whom uses the address-bar a lot, the expanding/shrinking has been a little rough to say the least. I have disabled it for now but in the future lets say post FF77 that will not be an option.

Normal menus and widgets just drop the list in one dimension and often on demand (down arrow). Megabar shadows and dimension change makes it popping "out the screen". Reduced motion pref changes nothing in this case.

(In reply to gwarser from comment #3)

Normal menus and widgets just drop the list in one dimension and often on demand (down arrow). Megabar shadows and dimension change makes it popping "out the screen". Reduced motion pref changes nothing in this case.

Agreed

(In reply to Asa Dotzler [:asa] from comment #1)

How do you deal with menus popping up or select widgets or other items that pop up on user activation?

The difference here is that even with animation disabled it still opens in two stages, first the enlargement and then the dropdown, which gives the illusion of animation. Most menus don't have that extra step, if it rendered all at once it should be much less problematic.

Note this was/is in response to Marco Bonardo, on a different bug but directed at me and my bug report

(In reply to Marco Bonardo [:mak] from comment #12)

(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #10)

    The dark theme can't be fully recommended to users for this purpose: bug 1566685 (Apart from that the Dark Mode extension is quite ok, but not perfect. Unfortunately it's often better to keep everything bright, but it has its own drawbacks.)

That means the real problem is the dark theme. I admit that's not a trivial problem to solve.

(In reply to Troy Janda from comment #11)

    The sudden expanding and shrinking are the issue for me being a frequent address bar user.

We'd love to hear more feedback from you!
Which part of the urlbar makes you suffer:

    it expands when you open a new tab. I'd expect this to be a lesser problem, because when the tab opens the urlbar is already expanded, so there's no movement.

I open links in new tab and wait for it to fully load before moving to the tab.

    it's larger when it expands the results pane on focus, if you set browser.urlbar.openViewOnFocus it is better

The act of expanding/shrinking simulates a strobe light. I type out most of my urls so accessing the url bar is a constant necessity for me and oce moving away from the url bar it shrinks imagine doing this 30-40 times in an hour.

    it's exactly the same with browser.urlbar.openViewOnFocus

    Try this click on the address bar move away and repeat several times.

But this is not a common operation for any user, I could find flashing defects in any software if I'd just repeat the same action continuously. We'd like to concentrate on your everyday needs more than simulated examples.

What is common to some might not be to others not sure how you can justify this statement, I am not talking about other software or conducting simulated examples, what I have described is my reality! these are the things that I PERSONALLY do each and everyday in my life to limit my triggers. I can't speak for neural sensitive/motion sensitivity I can talk about epilepsy.

No you can't be 100% trigger free some motion effects are different than others, some cause mild symptoms while others can trigger a full onset seizure. My trigger is stuff moving toward me or away from me in quick succession. As i use the bar 30-40 times an hour on average.

Status: UNCONFIRMED → NEW
Ever confirmed: true

Can you please explain better how it is with browser.urlbar.openViewOnFocus set to false? with that false we don't open the results pane, so the effect should be much smaller. I'd like to better understand the strobe effect when the panel doesn't open.

Flags: needinfo?(jandatroy)

(In reply to Marco Bonardo [:mak] from comment #7)

Can you please explain better how it is with browser.urlbar.openViewOnFocus set to false? with that false we don't open the results pane, so the effect should be much smaller. I'd like to better understand the strobe effect when the panel doesn't open.

It the popout and shrink that triggers my symptoms. Clicking on the url it expands, then navigating away from the bar it shrinks. I use the bar to type out address and I do this 20-30 times an hour typically on average the effects case my eyes to studder (Rapid eye movement) this in turn starts to make me dizzy. As I said I have not had a full blown epileptic episode but the symptoms are no less disrupting.

browser.urlbar.openViewOnFocus I have it set to false I also have the whole new bar disabled I just can't handle the constant expanding/shrinking. I have tried and do limit animations as I have said. Its a daily challenge to find ways to limit my triggers.

The strobe affect is like someone turning on and off a light, making quick forward movements or anything that causes the eyes to studder. movement downward is less symptomatic.

Some triggers are different for different people I am just explaining my triggers and why its a concern. For a person such as me using the url bar many times in an hour the effects are causing me problems.

Flags: needinfo?(jandatroy)

(In reply to Troy Janda from comment #8)

browser.urlbar.openViewOnFocus I have it set to false I also have the whole new bar disabled

I see, but in practice I'm asking if you tried to keep the new design enabled but browser.urlbar.openViewOnFocus disabled.

(In reply to Marco Bonardo [:mak] from comment #9)

(In reply to Troy Janda from comment #8)

browser.urlbar.openViewOnFocus I have it set to false I also have the whole new bar disabled

I see, but in practice I'm asking if you tried to keep the new design enabled but browser.urlbar.openViewOnFocus disabled.

Yes very limited the drop down part helps but after several click on the url and moving away still presents a problem.

maybe a pref to disable the expanding/shrinking in addition to the browser.urlbar.openViewOnFocus disabled pref

I have no issues or history with epilepsy, but I do have mild dyslexia and motion sickness in cars. I'll often open a new tab with an intent of doing something, and the bar expanding whether I used it or clicked one of the top sites kept distracting me from what it was I was trying to do. I first thought it was just the novelty of it, but I kept losing my focus after extended use.

I think the bar popping out makes it look a lot like a notification bar, and it's equally successful in stealing my attention. I tend to limit or disable system notifications when possible, on laptop and phone, to keep myself from being distracted and keep my work flow in tact. I also have a flip cover on my phone so that even if I do get a notification, I don't see it until I explicitly want to check if I got any.

I have not tried running it with animations disabled yet, so I'll try that now and see if that helps. I never had any issue with UI animation in general, but it might be that the animation itself is what brings my attention to the bar.

(In reply to maciej.hirsz from comment #12)

I have not tried running it with animations disabled yet, so I'll try that now and see if that helps. I never had any issue with UI animation in general, but it might be that the animation itself is what brings my attention to the bar.

As I said above, try setting browser.urlbar.openViewOnFocus to false, use the dark theme if you're distracted by flashes, and let us know if things improve.

Keywords: blocked-ux
Priority: -- → P2

I have dark theme on and openViewOnFocus set to false. Using it since yesterday evening with animations disabled it's definitely much better and something I can get used to. I wish I could disable the bar animation separately from OS settings, since I actually don't have any issues with my OS animations and quite like them (Gnome DE). I don't have issues with animations in general (no headaches or motion sickness from staring at them), my only issue is the distraction the bar animating triggers when I don't (intend to) interact with it, if that makes sense.

(In reply to Marco Bonardo [:mak] from comment #13)

(In reply to maciej.hirsz from comment #12)

I have not tried running it with animations disabled yet, so I'll try that now and see if that helps. I never had any issue with UI animation in general, but it might be that the animation itself is what brings my attention to the bar.

As I said above, try setting browser.urlbar.openViewOnFocus to false, use the dark theme if you're distracted by flashes, and let us know if things improve.

(In reply to Marco Bonardo [:mak] from comment #9)

(In reply to Troy Janda from comment #8)

    browser.urlbar.openViewOnFocus I have it set to false I also have the whole new bar disabled

I see, but in practice I'm asking if you tried to keep the new design enabled but browser.urlbar.openViewOnFocus disabled.

Yes very limited the drop down part helps but after several click on the url and moving away still presents a problem.

Blocks: 1630275
No longer blocks: urlbar-update-1
Whiteboard: [access-p2]

I personally do not like the urlbar expansion either because I find it distracting. Recently I found a way using userChrome.css to disable this expansion. Maybe you coud try it and see if it works better for you. Source

/* --- Disable expanding --- */
#urlbar[breakout][breakout-extend] {
  top: calc((var(--urlbar-toolbar-height) - var(--urlbar-height)) / 2) !important;
  left: 0 !important;
  width: 100% !important;
}

#urlbar[breakout][breakout-extend] > #urlbar-input-container {
  height: var(--urlbar-height) !important;
  padding-block: 0px !important;
  padding-inline: 0px !important;
}

#urlbar[breakout][breakout-extend][breakout-extend-animate] > #urlbar-background {
  animation-name: none !important;
}

(In reply to trinywiky from comment #16)

I personally do not like the urlbar expansion either because I find it distracting. Recently I found a way using userChrome.css to disable this expansion. Maybe you coud try it and see if it works better for you. Source

/* --- Disable expanding --- */
#urlbar[breakout][breakout-extend] {
  top: calc((var(--urlbar-toolbar-height) - var(--urlbar-height)) / 2) !important;
  left: 0 !important;
  width: 100% !important;
}

#urlbar[breakout][breakout-extend] > #urlbar-input-container {
  height: var(--urlbar-height) !important;
  padding-block: 0px !important;
  padding-inline: 0px !important;
}

#urlbar[breakout][breakout-extend][breakout-extend-animate] > #urlbar-background {
  animation-name: none !important;
}

To be a bit simpler I have just flipped the pref to false to disable it. Ill have to move to this or another solution once they take away those prefs, from what I have heard this will be in FF77. If this is so, FF76 will be my last.

Keywords: losing-users

Resetting severity to default of --.

Points: --- → 5

May I ask what points are? I saw Mr. Bonardo make a change adding 5 points, Sorry if this has been asked before still new to the process.

It's just an estimate of the difficulty to fix the bug, depending on it scomplexity and needed interactions with other people/teams. Nothing of interest for users, we use it to estimate team velocity.

We're happy that you're helping us out by filing a bug report and providing useful information that'll help our engineers move towards a solution to the issue!
If you have additional relevant information to share, please feel free to post them to the bug. But since this is a work tracker, I'd like to ask if you could join us on Matrix (on chat.mozilla.org, we're at the #search channel) for any other questions or concerns you might have.

Thank you.

Updating the Accessibility Team's impact assessment to conform with the new triage guidelines. See https://wiki.mozilla.org/Accessibility/Triage for descriptions of these whiteboard flags.

Whiteboard: [access-p2] → [access-s3]
Blocks: 1478597
Assignee: nobody → htwyford
Keywords: blocked-ux

We're going to disable the expansion effect when the panel is closed and the "Reduce motion" OS preference is enabled. Since there's a great deal of interest in this bug, I'll note that we're also looking at modifying the address bar design in compact mode over in bug 1630508.

Status: NEW → ASSIGNED
Iteration: --- → 79.1 - June 1 - June 14

(In reply to Harry Twyford [:harry] from comment #28)

We're going to disable the expansion effect when the panel is closed and the "Reduce motion" OS preference is enabled. Since there's a great deal of interest in this bug, I'll note that we're also looking at modifying the address bar design in compact mode over in bug 1630508.

Panel? Is that the urlbar not understanding, so the urlbar will not expand/shrink if the "Reduce motion" OS preference is enabled?

The panel displays results. So there will be no expansion when opening a new tab, but there will be an expansion once one interacts with the address bar, since we need to show results.

(In reply to Harry Twyford [:harry] from comment #30)

The panel displays results. So there will be no expansion when opening a new tab, but there will be an expansion once one interacts with the address bar, since we need to show results.

Not sure I understand, Im sorry, so clicking the urlbar (panel) which triggers the expansion will be disabled? but the drop down results will remain the same or I am lost as to what exactly you mean.

I open all links in new tabs and wait a bit before switching to that tab to help minimize the effects. However since I use the urlbar a lot the expansion/shrinking when its in focus and moving away is the main issue. I think that a simple pref to disable that expansion is not unreasonable.

Attached image new states.png

Right now, the address bar has three states:

  1. Unfocused
  2. Focused & expanded
  3. Focused, expanded, & open

State 1 is what you see when you're not interacting with the address bar. You enter state 2 when you open a new tab but haven't interacted with the address bar yet. You enter state 3 after clicking or typing in the address bar, and results are shown in the dropdown panel.

My patch just changes state 2 so it's not expanded. This will eliminate the motion effect when opening a new tab. I've attached a screenshot to illustrate what things will look like after my patch is applied.

Not sure how this relates to my bug report. It is the expanding/shrinking of the urlbar, not opening a new tab.

when clicking the urlbar it expands, when moving away, or clicking outside the urlbar is shrinks. this is my issue because as many times that I use the urlbar the constant expansion/shrinking is causing my issues. New tab was never my issue as when I right click to open links in new tabs I wait till the tab loads before switching to it.

By expanding, do you mean how we show Top Sites when you click on the Urlbar? You can disable that in 78+ in about:preferences > Privacy & Security > Address bar > Uncheck "Top sites". In <78 you can disable the pref browser.urlbar.openViewOnFocus. You and Marco discussed that earlier in the thread. With that behaviour disabled, the address bar will not move when it is clicked once my patch is applied.

It might be easier to try my patch out in Nightly once it lands and offer feedback on it.

(In reply to Harry Twyford [:harry] from comment #35)

By expanding, do you mean how we show Top Sites when you click on the Urlbar? You can disable that in 78+ in about:preferences > Privacy & Security > Address bar > Uncheck "Top sites". In <78 you can disable the pref browser.urlbar.openViewOnFocus. You and Marco discuss that earlier in the thread. With that behaviour disabled, the address bar will not move when it is clicked once my patch is applied.

It might be easier to try my patch out in Nightly once it lands and offer feedback on it.

By expanding, do you mean how we show Top Sites
No, I already have browser.urlbar.openViewOnFocus set to false and I have unclecked the topsites

My issue is, open Firefox let it load your home page, then click inside the urlbar. It expands, now if you click outside of the urlbar the urlbar shrinks. try doing this over 30-40 times an hour. I hope that this explains this better.

edited for format issue, Harry asked,
By expanding, do you mean how we show Top Sites

my responce,

No, I already have browser.urlbar.openViewOnFocus set to false and I have unclecked the topsites

Troy, per Harry's responses and the image he posted, the expansion will not occur when you click in the bar. It will expand if you type and you get suggestions in the bar, however. Does that help?

(In reply to Asif Youssuff from comment #38)

Troy, per Harry's responses and the image he posted, the expansion will not occur when you click in the bar. It will expand if you type and you get suggestions in the bar, however. Does that help?

His images is for newtab page I am talking about just the act of clicking the urlbar and moving away from the urlbar

(In reply to Asif Youssuff from comment #38)

Troy, per Harry's responses and the image he posted, the expansion will not occur when you click in the bar. It will expand if you type and you get suggestions in the bar, however. Does that help?

browser.urlbar.openViewOnFocus set to false stops the dropdown and the suggestions

Steps

  1. open Firefox,
  2. click inside the urlbar,
    Result it expands before you even start typing.
  3. move/clicking outside the urlbar,
    Results the urlbar shrinks to its unfocused state.

I already control how tabs are loaded, I right click link and open in newtab and only switch to that tab once its fully loaded.

(In reply to Troy Janda from comment #40)

Steps

  1. open Firefox,
  2. click inside the urlbar,
    Result it expands before you even start typing.
  3. move/clicking outside the urlbar,
    Results the urlbar shrinks to its unfocused state.

I already control how tabs are loaded, I right click link and open in newtab and only switch to that tab once its fully loaded.

In this bug, Harry has made it so that step 2 will not expand. Refer to the image.

on newtab(In reply to Asif Youssuff from comment #41)

(In reply to Troy Janda from comment #40)

Steps

  1. open Firefox,
  2. click inside the urlbar,
    Result it expands before you even start typing.
  3. move/clicking outside the urlbar,
    Results the urlbar shrinks to its unfocused state.

I already control how tabs are loaded, I right click link and open in newtab and only switch to that tab once its fully loaded.

In this bug, Harry has made it so that step 2 will not expand. Refer to the image.

On "Newtab" clearly Im not talking about on newtab

(In reply to Troy Janda from comment #42)

On "Newtab" clearly Im not talking about on newtab

I was just using the new tab as an example. I expect my patch will do what you are requesting. To avoid creating too much bug mail, please wait for the patch to land then let us know if it does what you expect.

(In reply to Harry Twyford [:harry] from comment #43)

(In reply to Troy Janda from comment #42)

On "Newtab" clearly Im not talking about on newtab

I was just using the new tab as an example. I expect my patch will do what you are requesting. To avoid creating too much bug mail, please wait for the patch to land then let us know if it does what you expect.

is it not what this is for a discussion, input and debate? Can I ask when this is expected to land? I don't use beta, or nightly because it too much work to reset up to act like stable.

Attached video no_expand.mov

(In reply to Troy Janda from comment #44)

(In reply to Harry Twyford [:harry] from comment #43)
is it not what this is for a discussion, input and debate?

Yes, but I think we're in agreement. You don't want the address bar to expand when it is clicked, and my patch does that.

Can I ask when this is expected to land?

It will most likely be in Firefox 79. We may still be able to get it into Firefox 78 it it doesn't create any additional issues. Since you don't use Nightly or Beta, you won't see the change for at least a few weeks. Here's a screen recording instead. I click in the address bar a few times, type a bit, press Escape, then open a new tab.

It's a bit difficult to follow the discussion, but I also guess the patch is going to fix the problem. You may have never thought about it, but open source software isn't free as in royalty free. Rather it is free of charge, but depends on a user base that actually tests alpha/beta versions, and ideally is able to hand in patches or bug reports for problems that arise.

To make it short: if you want to test a proposed fix from nightly, just backup your profile and go for it. If you can't do it on your own, go ask a friend to help you with getting the verification you so much demand.

(In reply to Harry Twyford [:harry] from comment #45)

Created attachment 9155391 [details]
no_expand.mov

(In reply to Troy Janda from comment #44)

(In reply to Harry Twyford [:harry] from comment #43)
is it not what this is for a discussion, input and debate?

Yes, but I think we're in agreement. You don't want the address bar to expand when it is clicked, and my patch does that.

Can I ask when this is expected to land?

It will most likely be in Firefox 79. We may still be able to get it into Firefox 78 it it doesn't create any additional issues. Since you don't use Nightly or Beta, you won't see the change for at least a few weeks. Here's a screen recording instead. I click in the address bar a few times, type a bit, press Escape, then open a new tab.

yes I see that is what I am talking about and I assume that browser.urlbar.openViewOnFocus set to false stops the dropdown and the suggestions and you type? I am hoping for zero expansion even while typing. However you patch seems to be great.

(In reply to tt_1 from comment #46)

It's a bit difficult to follow the discussion, but I also guess the patch is going to fix the problem. You may have never thought about it, but open source software isn't free as in royalty free. Rather it is free of charge, but depends on a user base that actually tests alpha/beta versions, and ideally is able to hand in patches or bug reports for problems that arise.

To make it short: if you want to test a proposed fix from nightly, just backup your profile and go for it. If you can't do it on your own, go ask a friend to help you with getting the verification you so much demand.

my disability makes it difficult enough to use Firefox but with the settings and addons I am able to tolerate it. Setting up additional Firefox editions such as Beta, and Nightly is a tall ask to get it to behave in a manor that does not make it trigger my epilepsy. Ill have to wait for this patch to land on stable and check back here for additional information as it becomes available.

(In reply to Troy Janda from comment #47)

I am hoping for zero expansion even while typing.

You can set browser.urlbar.maxRichResults to 0 and there will be no dropdown when you type. Once this patch lands, there would be no motion whatsoever.

(In reply to Harry Twyford [:harry] from comment #49)

(In reply to Troy Janda from comment #47)

I am hoping for zero expansion even while typing.

You can set browser.urlbar.maxRichResults to 0 and there will be no dropdown when you type. Once this patch lands, there would be no motion whatsoever.

Thank you Harry for your time and help.

Question, could that patch be applied to the browser.urlbar.openViewOnFocus pref, when set to false also disables the expansion for people that just don't like the expanding feature? I am asking for the people in the Reddit thread who are not in my situation of being epileptic.

(In reply to Troy Janda from comment #51)

Question, could that patch be applied to the browser.urlbar.openViewOnFocus pref, when set to false also disables the expansion for people that just don't like the expanding feature? I am asking for the people in the Reddit thread who are not in my situation of being epileptic.

The input field extension and openViewOnFocus (Top Sites actually) are different features with different characteristics, it wouldn't make sense to group them under the same pref. Additionally Firefox 78 already contains a visual pref to disable Top Sites.

(In reply to Marco Bonardo [:mak] from comment #52)

(In reply to Troy Janda from comment #51)

Question, could that patch be applied to the browser.urlbar.openViewOnFocus pref, when set to false also disables the expansion for people that just don't like the expanding feature? I am asking for the people in the Reddit thread who are not in my situation of being epileptic.

The input field extension and openViewOnFocus (Top Sites actually) are different features with different characteristics, it wouldn't make sense to group them under the same pref. Additionally Firefox 78 already contains a visual pref to disable Top Sites.

Its not the Top sites I am referring to Mr Bonardo, its the expanding that happen when clicking the urlbar. Not the drop down, not the Topsites just the the expanding that happen when clicking the urlbar in to focus, and the shrinking when clicking outside the urlbar. The above patch will disable that if/when the "reduce motion" OS is enabled & browser.urlbar.openViewOnFocus set to false. Which will be very helpful for me and those with my condition.

I was asking that why can't a pref be made to simply disable the expanding all together? if the user so chooses.

(In reply to Troy Janda from comment #53)

I was asking that why can't a pref be made to simply disable the expanding all together? if the user so chooses.

We're providing a solution for people who actually have accessibility issues with continuous UI changes, prefer-reduced-motion is exactly for that. We can't meet the subjective taste of everyone, of course people can use the same accessibility method to disable the expansion, we can't/won't prevent that.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/153e280928ee
Don't expand the Urlbar when reduce motion is on. r=dao
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

(In reply to Pulse from comment #58)

Just so it's on the table, There is nothing in KDE that will cause the desired effect of stopping the address bar expansion. Works in Windows 10. The only option for KDE seems to be ui.prefersReducedMotion which does seem to work. This should be a made an option under preferences.

Tested in today's nightly Build 20200610214041.

I managed to get the animations disabled via the GTK settings.ini. I'd missed it earlier but was reminded about the process on reddit

(In reply to Pulse from comment #59)

I managed to get the animations disabled via the GTK settings.ini. I'd missed it earlier but was reminded about the process on reddit

Thanks, this may be useful to other users.

Address bar is still expanding when I start typing, check this out in Firefox 79.0a1 (2020-06-10) (64-bit)
check this: https://imgur.com/bRZXJbg

yes, that is expected, we must show the results pane.

Comment on attachment 9155353 [details]
Bug 1629303 - Don't expand the Urlbar when reduce motion is on. r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: This is an accessibility fix for the new address bar ("megabar"). If declined, people with epilepsy or who are otherwise sensitive to motion would not have a way to disable all motion in the address bar. It it worth noting that 78 ESR will be the first ESR version to get the new address bar, and we'd like for this accessibility fix to be included when it launches on that channel.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Visual-only fix. There is only a small amount of code involved, so backout would be simple.
  • String changes made/needed:
Attachment #9155353 - Flags: approval-mozilla-beta?

Comment on attachment 9155353 [details]
Bug 1629303 - Don't expand the Urlbar when reduce motion is on. r?dao

approved for 78.0b7

Attachment #9155353 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 1647833
Blocks: 1647833
No longer depends on: 1647833
Severity: normal → S2

(In reply to Marco Bonardo [:mak] from comment #62)

yes, that is expected, we must show the results pane.

Yes you must show the results pane, but that doesn't answer why the bar must be expanded.

Why can't the expansion of the bar be completely disabled and results be shown below it like it used to be?

As Troy Janda mentioned several times in this thread, it is not the drop down that is an issue, it is the expansion of the bar it self outwards in all directions that is triggering. I also have the same issues as Troy. I never had problems with search suggestions appearing below the address bar in the past 15 years of using internet browsers, it is simply the expansion of the address bar that is jarring/troubling.

Instead of truly addressing this accessibility issue for your users, you instead tell them to disable functionality (disable all suggestion ability) in order to address what is on your part a subjective design decision.

Firefox 89 has no expansion and is being released these days (tomorrow I think).

Is the final release of Firefox 89 different than what's in the beta channel?

I ask because it does still expand the address bar when displaying rich results. And I also found a what I hope is a bug, with maxRichResults set to 0, the bar will expand breifly and then go back to normal when you click on it which is the absolute worst I've seen yet.

However, I discovered if I enable the separate search bar, it behaves nicely and has no expansion with a nice drop down element appearing with suggestions. Why can't the address bar behave like the search bar?

(In reply to Bun-Bun from comment #68)

I ask because it does still expand the address bar when displaying rich results.

This bug is about input field expansion when no results are shown, there's no plan to avoid expansion when there are results, and I'm quite sure it will hardly be a goal.

And I also found a what I hope is a bug, with maxRichResults set to 0, the bar will expand breifly and then go back to normal when you click on it which is the absolute worst I've seen yet.

We think urlbar results add value to the browser for our users, we spend resources to improve them and have very interesting plans for the future. Thus, there's no goal or plan to hide urlbar results.

This bug is about input field expansion when no results are shown, there's no plan to avoid expansion when there are results, and I'm quite sure it will hardly be a goal.

Why is there no plan for even adding an option to disable the expansion?

If we're talking about value for users then we can do a quick google search and see that it's a quite popular request.

Currently users have to play with https://www.userchrome.org/megabar-styling-firefox-address-bar.html#mbarstyler to disable the bar enlargement.

While the value for showing urlbar results is pretty clear and there's no questioning about that since extra features are almost always a good thing, I fail to understand why not having extra options for a (disliked by many) subjective design decision is seen as adding value for users instead of the opposite.

(In reply to aru from comment #70)

If we're talking about value for users then we can do a quick google search and see that it's a quite popular request.

I'm sorry, but I think you are conflating multiple issues into the same feedback request.
Most (almost all) of the feedback we got was about the input field expansion when focusing the urlbar, for example in the new tab page. That is already resolved in Firefox 89.
Some feedback was about not opening the urlbar on click when there's no search string, and for that we already provided a visible Top Sites option in Preferences.
Very small amount of feedback was about not expanding the results pane at all, and we don't plan to address that, because we think the current state is the best for our users.

So basically all the feedback has been addressed, but the request to not open the urlbar at all, that in our opinion would be a footgun option.
If you want to provide a screenshot/video explaining your feedback in a more detailed way, I'm happy to check it.

(In reply to Marco Bonardo [:mak] from comment #69)

(In reply to Bun-Bun from comment #68)

This bug is about input field expansion when no results are shown, there's no plan to avoid expansion when there are results, and I'm quite sure it will hardly be a goal.

No, this bug is about the expansion and shrinking of the input field at all. Troy asked for his accessibility reasons (which I also suffer from) to have a way to disable the expansion in it's entirety even when showing results. gwarser replied to him very early on "Normal menus and widgets just drop the list in one dimension and often on demand (down arrow). Megabar shadows and dimension change makes it popping "out the screen". Reduced motion pref changes nothing in this case." To which tony agreed with in the next post. Later on your team decided to talk about new tab page and a bunch of other things like you are to which Tony asked why you are bringing that up as that is not what he talking about. He was talking about the expansion/shrinkage in all use cases.

You also mention later that accessibility issues are important to you so you put some urgency to this bug. Then why aren't you reading and listening to what we are saying? You've completely glossed over and ignored the critical points in this thread. Troy even stated that with the upcoming removal of the option to disable all expansion of the input field that he will no longer use firefox.

"To be a bit simpler I have just flipped the pref to false to disable it. Ill have to move to this or another solution once they take away those prefs, from what I have heard this will be in FF77. If this is so, FF76 will be my last."

And since he only got a workaround From Harry Twyford, by setting rich results to 0, he gave up and stopped responding.

We think urlbar results add value to the browser for our users, we spend resources to improve them and have very interesting plans for the future. Thus, there's no goal or plan to hide urlbar results.

I agree! But then why in order to disable the expansion and shrinkage for a very valid accessibility reason are you suggesting that all results be disabled? Harry Twyford replied to Troy:

"
(In reply to Troy Janda from comment #47)

I am hoping for zero expansion even while typing.

You can set browser.urlbar.maxRichResults to 0 and there will be no dropdown when you type. Once this patch lands, there would be no motion whatsoever.
"
Now to clarify, Troy previously stated the drop down is less of an issue, it's the expansion/shrinking of the input field that is the issue.

"The strobe affect is like someone turning on and off a light, making quick forward movements or anything that causes the eyes to studder. movement downward is less symptomatic."

I like having history auto complete and ability to switch to open tabs from the results (for some reason setting rich results to 0 disables auto complete). But in order to stop the expanding and shrinking of the input field that is triggering to my symptoms, I have to disable all results in their entirety. This to me is the definition of regression. My current

However, there is now a bug in FF89 where if rich results is set to 0, the input field expands and the result pane appears for a brief moment. This is the absolute worse for epilepsy triggers.

Here is a link to a video showing that behaviour as well as a screen shot attempting to explain my issues which agree with Troy who made this bug in the first place.

https://c.nyy.ca/s/ApP5LNacRb4LL4J

If you need me to upload these files in a different method I will, I don't see a way to share pictures or videos in this editor.

(In reply to Marco Bonardo [:mak] from comment #71)

(In reply to aru from comment #70)

If we're talking about value for users then we can do a quick google search and see that it's a quite popular request.

I'm sorry, but I think you are conflating multiple issues into the same feedback request.
Most (almost all) of the feedback we got was about the input field expansion when focusing the urlbar, for example in the new tab page. That is already resolved in Firefox 89.
Some feedback was about not opening the urlbar on click when there's no search string, and for that we already provided a visible Top Sites option in Preferences.
Very small amount of feedback was about not expanding the results pane at all, and we don't plan to address that, because we think the current state is the best for our users.

So basically all the feedback has been addressed, but the request to not open the urlbar at all, that in our opinion would be a footgun option.
If you want to provide a screenshot/video explaining your feedback in a more detailed way, I'm happy to check it.

No, they are not conflating multiple issues. The request to disable all expansion of the input field is a common one. For some reason you are choosing to be blind to all that feedback and the many threads on reddit about it. People are resorting to css modifications which are difficult for people with accessibility issues to do.

Why is it such a difficult concept to understand that we need a way to disable the expansion of the input field while still showing the results pane below like it used to be and like how the separate search bar currently behaves?

(In reply to Bun-Bun from comment #72)

(In reply to Marco Bonardo [:mak] from comment #69)

(In reply to Bun-Bun from comment #68)

I like having history auto complete and ability to switch to open tabs from the results (for some reason setting rich results to 0 disables auto complete). But in order to stop the expanding and shrinking of the input field that is triggering to my symptoms, I have to disable all results in their entirety. This to me is the definition of regression. My current

I realize after that I didn't complete this thought and I see no way to edit my post.

My current work around is to use compact mode, as it reduces the amount of expansion I am exposed to, and use the separate search bar for the majority of my interactions with searching. I was using rich results max 0 but as I stated in my previous post that is not resulting in much worse behaviour of flashing the results pane briefly on click. This work around is not ideal as interacting with URLs still causes the trigger behaviour for my symptoms and I do not get history/tab search. Also you have deprecated compact mode so I assume in a future build I will be forced to go to normal mode.

Also, you did acknowledge the size of expansion is an issue for people and adjusted the amount of expansion for compact mode and now all modes in FF89, why then is it so hard to change it to zero expansion, while still displaying the results pane below, with reduced motion enabled?

(In reply to Bun-Bun from comment #72)

However, there is now a bug in FF89 where if rich results is set to 0, the input field expands and the result pane appears for a brief moment. This is the absolute worse for epilepsy triggers.

Was this bug filed? That's not expected and should be fixed, since it's a recent regression it has nothing to do with this specific bug, it should be filed apart and fixed. There has been a misunderstanding here, sorry about that.

I agree! But then why in order to disable the expansion and shrinkage for a very valid accessibility reason are you suggesting that all results be disabled?

If the problem is flashing, removing those few pixel of expansion is not going to help at all with flashing. Two things would help with flashing:

  1. Picking a theme that has a urlbar panel dark color, or just maintains the color of the input field, and there are many of those.
  2. not showing results at all.

Regarding the panel growth, our accessibility team analyzed the epilepsy problem related to growing the panel but didn't identify specific problems with that, yet. Again I suggest to pick a theme you're more comfortable with. We'll keep listening for feedback about it and act accordingly.

(In reply to Marco Bonardo [:mak] from comment #75)

Regarding the panel growth, our accessibility team analyzed the epilepsy problem related to growing the panel but didn't identify specific problems with that, yet.

I've re-read through this bug a couple of times and from what I can tell, there is one report, the original reporter, Troy, who has epilepsy, who says there were interactions that created a strobe-like effect which triggered epilepsy symptoms. If that is still the case 26 months later, we should investigate the strobe effect and try to fix it.

Troy, I am having difficult reproducing a strobe-like effect.

Are you saying that the pop-up being several pixels wider than the initial text area creates a strobe effect? I'm not seeing a strobe effect from that.

I understand that it may be difficult, but can you make a screen recording of this strobe effect? I have tried repeatedly to create a strobe effect interacting with the address bar and its pop-up and cannot make it happen.

To others commenting here: this bug is about a possible disability access issue related to strobe effects and epilepsy and so if you have something specific about epilepsy you'd like us to understand, that feedback is welcome. Otherwise, this is not the place for general advocacy around how the addressbar functions.

(In reply to Asa Dotzler [:asa] from comment #76)

(In reply to Marco Bonardo [:mak] from comment #75)

Regarding the panel growth, our accessibility team analyzed the epilepsy problem related to growing the panel but didn't identify specific problems with that, yet.

I've re-read through this bug a couple of times and from what I can tell, there is one report, the original reporter, Troy, who has epilepsy, who says there were interactions that created a strobe-like effect which triggered epilepsy symptoms. If that is still the case 26 months later, we should investigate the strobe effect and try to fix it.

Troy, I am having difficult reproducing a strobe-like effect.

Are you saying that the pop-up being several pixels wider than the initial text area creates a strobe effect? I'm not seeing a strobe effect from that.

I understand that it may be difficult, but can you make a screen recording of this strobe effect? I have tried repeatedly to create a strobe effect interacting with the address bar and its pop-up and cannot make it happen.

To others commenting here: this bug is about a possible disability access issue related to strobe effects and epilepsy and so if you have something specific about epilepsy you'd like us to understand, that feedback is welcome. Otherwise, this is not the place for general advocacy around how the addressbar functions.

I've read through all of Troy's comments and the way I understand him is that the expansion and shrinking of the url bar input field causes a strobe like effect which is a trigger to his epilepsy. He never said there is a strobing happening, but that the act of expanding and shrinking is like a strobe effect. I have the same epilepsy triggers and find firefox's expanding URL bar to be very triggering. The separate search bar that doesn't expand doesn't cause me any issues even when it displays results below.

The fix is to stop all expansion of the URL bar when reduced motion is enabled, which is what Troy asked for.

(In reply to Marco Bonardo [:mak] from comment #75)

Regarding the panel growth, our accessibility team analyzed the epilepsy problem related to growing the panel but didn't identify specific problems with that, yet. Again I suggest to pick a theme you're more comfortable with. We'll keep listening for feedback about it and act accordingly.

So because your accessibility teams deams Troy's and mine issue an imaginary one, we get ignored and given a on fix as a result?

I've already tried different themes to stop the highlighting on focus, that doesn't change that the url bar it self grows which when clicking in and out of the bar appears to me as an strobe effect and triggers my symptoms. That growing effect is unnatural to the UI as every other input field does not behave in this manner. Other input fields have separate results panes that appear below the field and thus to my eyes/brains is separate enough to not cause symptoms.

(In reply to Asa Dotzler [:asa] from comment #76)

I understand that it may be difficult, but can you make a screen recording of this strobe effect? I have tried repeatedly to create a strobe effect interacting with the address bar and its pop-up and cannot make it happen.

I've attempted further analysis by playing a video of the addressbar opening and closing repeatedly in the PEAT (Photosensitive Epilepsy Analysis Tool) and it does not provide any warnings in its analysis of the Firefox addressbar. It doesn't even offer a "caution" for repeatedly opening and closing the addressbar.

(In reply to Asa Dotzler [:asa] from comment #79)

(In reply to Asa Dotzler [:asa] from comment #76)

I understand that it may be difficult, but can you make a screen recording of this strobe effect? I have tried repeatedly to create a strobe effect interacting with the address bar and its pop-up and cannot make it happen.

I've attempted further analysis by playing a video of the addressbar opening and closing repeatedly in the PEAT (Photosensitive Epilepsy Analysis Tool) and it does not provide any warnings in its analysis of the Firefox addressbar. It doesn't even offer a "caution" for repeatedly opening and closing the addressbar.

Yet here I am, telling you, having the growing/shrinking of the bar causing me symptoms where input fields that don't grow do not trigger my symptoms.

And the very first thing Troy said "the expanding and shrinking of the address bar has caused triggers with my epilepsy. the sudden expanding and then when moving away from the address bar has a similar effect as a strobe light and has triggerd mild symptoms of epilepsy such as losing focus, feeling mildly dizzy, and eye studdering (eye movements like little jerks)".

What is it going to take for you to listen to us?

(In reply to Bun-Bun from comment #80)

What is it going to take for you to listen to us?

I'm trying to listen. It seems like you're frustrated and that's affecting how you reply here. I'm encouraging you to keep the discussion civil as this is our workplace and we intend it to stay civil.

I'm trying to understand if what I'm seeing is what you're seeing. Browsers are complex and computers are varied in how performant they are and so it's not always safe to assume what one user sees is what another user sees.

As noted, I cannot find any literature or testing tools that suggests this bit of Firefox UI is a widespread problem for people with photosensitive epilepsy. I hear that you are experiencing a difficulty and that the original reporter is as well, but that does not mean that Firefox is causing problems for other people with photosensitive epilepsy. It is difficult making product decisions with a sample size of two so I've consulted the literature and the tools for testing for photosensitive epilepsy.

Perhaps you are more plugged in to the literature or tools and can point me to an explanation that would help me understand how a pop-up that's bigger than the field that triggered the pop-up is an epilepsy trigger.

The medical literature, accessibility literature, accessibility standards, etc. often takes time to catch up with new designs and technology, or with unusual needs. Sometimes accessibility standards sacrifice unusual needs, such as those involving photosensitive epilepsy, to prioritize other needs, thus the use of strobe lights and other flashing lights... everywhere.

Now when I click on the address + search bar, it expands, and then it stays expanded. I have to click elsewhere for it to shrink. So from my perspective, the bar itself seems self-limiting. I have to click here, then click there, then here, then there for it to keep going. I don't have to do anything for it to stop. But the suggestions are more of a challenge.

It sounds like for some of you, you don't have to click elsewhere for it to shrink, that can happen just mousing about.

(In reply to Bun-Bun from comment #72)

However, there is now a bug in FF89 where if rich results is set to 0, the input field expands and the result pane appears for a brief moment. This is the absolute worse for epilepsy triggers.

was this filed yet?

(In reply to MarjaE from comment #82)

Now when I click on the address + search bar, it expands, and then it stays expanded. I have to click elsewhere for it to shrink.

In Firefox 89, if you disable Top Sites in about:preferences#privacy when you click on the urlbar nothing happens, it just gets a focus ring. Did you try Firefox 89 or are you speaking about an older version?

And this is exactly the problem of this bug, it conflates the old behavior of expanding the field on focus (fixed on 89), with expanding the results pane, with Top Sites (fixed by unsetting pref), with a specific regression in 89 (not yet filed). And then it becomes unactionable to us because there's too many different things ongoing.

(In reply to Marco Bonardo [:mak] from comment #83)

(In reply to Bun-Bun from comment #72)

However, there is now a bug in FF89 where if rich results is set to 0, the input field expands and the result pane appears for a brief moment. This is the absolute worse for epilepsy triggers.

was this filed yet?

I have not filed it. Given the lack of listening to your users in this bug I'm not exactly motivated to put forth the effort to make a bug about it.

(In reply to MarjaE from comment #82)

Now when I click on the address + search bar, it expands, and then it stays expanded. I have to click elsewhere for it to shrink.

In Firefox 89, if you disable Top Sites in about:preferences#privacy when you click on the urlbar nothing happens, it just gets a focus ring. Did you try Firefox 89 or are you speaking about an older version?

This is incorrect. Even with reduced motion and top sites disabled clicking in the url bar still expands it. And yes with FF89.

And this is exactly the problem of this bug, it conflates the old behavior of expanding the field on focus (fixed on 89), with expanding the results pane, with Top Sites (fixed by unsetting pref), with a specific regression in 89 (not yet filed). And then it becomes unactionable to us because there's too many different things ongoing.

No, it is not conflating because you have it wrong. This bug is not about expanding the field on focus, that is your interpretation of it. Troy asked to stop all expansion of the bar, even when typing. It's you and your team that did not listen to Troy and instead chose to interpret it as only with on click. Top sites setting has nothing to do with this, again was your team not listening to Troy and saying that was the problem. The only solution you have provided to Troy and myself is disable all rich results which is a terrible solution as the results and auto complete are valuable to us.

(In reply to Asa Dotzler [:asa] from comment #81)

(In reply to Bun-Bun from comment #80)

What is it going to take for you to listen to us?

I'm trying to listen. It seems like you're frustrated and that's affecting how you reply here. I'm encouraging you to keep the discussion civil as this is our workplace and we intend it to stay civil.

Yes I am frustrated. I am frustrated because despite Troy and I having given clear feedback into the UI element triggering our symptoms and a simple solution (disable all URL bar expansion with reduced motion enabled) you continue to stand your ground and prefer a subjective design decision instead of helping your users not have headaches or motion sickness when using your product.

It would appear that I need to get a doctorate in neurological conditions and/or vestibular disorders and write a thesis on URL bar expansion before you will listen to me. I don't know the science behind it nor do I care. What I care about is that when I look at expanding URL bars (not only in firefox, but also in the many other chromium based browsers that have adopted the same terrible design) I get triggers to my conditions that make my use time of your product limited as I have to take breaks to clear the headaches and feeling of sickness. If I had to guess it's because I am focused on the text and the bar itself growing/shrinking when I type, copy/paste, change a url is close enough to my eye focus that it is causing me issues. The results pane appearing below other input fields is far enough away from my focus on the text where as the expanding/shrinking of the bar takes my eye with it.

Technically I know it's a simple fix on your end as others on reddit and other places have been using CSS rules to fix this for themselves. I can't figure out how to do that and nor am I allowed to make those modifications on my work computer. https://www.userchrome.org/megabar-styling-firefox-address-bar.html#mbarstyler

Also you have already demonstrated an understanding of the issue and reduced the amount of growth in FF89 new UI so I can not comprehend why you are butting heads about reducing it a few more pixels to 0 growth with prefers reduced motion enabled.

(In reply to Bun-Bun from comment #84)

I have not filed it. Given the lack of listening to your users in this bug I'm not exactly motivated to put forth the effort to make a bug about it.

I think this attitude is not useful. We are answering here and asking you questions because we listen.

This is incorrect. Even with reduced motion and top sites disabled clicking in the url bar still expands it. And yes with FF89.

Could you please provide me steps to reproduce, so I can evaluate whether it's expected or a bug?

(In reply to Bun-Bun from comment #85)

Technically I know it's a simple fix on your end as others on reddit and other places have been using CSS rules to fix this for themselves.

I'm sorry, but that's not true. With simple CSS rule you can do whatever you wish, but we have to ensure a quality bar of every fix to hundred millions users. Let's not enter this rabbit hole, things from the outside, when you do them for 10 users, are very different, I know because I've been a volunteer contributing code for free to Mozilla for quite some time, before working for Mozilla.

Accessibility Severity: --- → s3
Whiteboard: [access-s3]
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: