onFocus keeps on firing.

VERIFIED DUPLICATE of bug 58441

Status

()

Core
Event Handling
VERIFIED DUPLICATE of bug 58441
16 years ago
16 years ago

People

(Reporter: Prashant Desale, Assigned: joki (gone))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
This is MacOSX specific.

onFocus event occurs 3 times where it should occur only once.

BUILDS: 2002-08-13-05-1.0

STEPS TO REPRODUCE:
1] Load Testcase I'm going to attach.
2] click on any input.

EXPECTED RESULTS:
you should see alert showing 'onFocus Event Was Fired' & you should see this
alert only once.

ACTUAL RESULTS:
you see alert showing 'onFocus Event Was Fired' three times.
(Reporter)

Comment 1

16 years ago
Created attachment 95461 [details]
Testcase

Comment 2

16 years ago
"Three times" is an understatement.. i had to kill mozilla to get away from that
alert..
This happens because the alert taking focus blurs the input and the input gets
refocused when the alert is taken down.

Isn't there a bug on eliminating that behavior?
Whiteboard: DUPEME
(Reporter)

Comment 4

16 years ago
Updating Summary.
onFocus keeps on firing.
This is occuring on Anchor too.
cc'ing moied
Summary: onFocus occurs 3 times where it should occur only once. → onFocus keeps on firing.

Comment 5

16 years ago
This works for me (1 focus alert per click in any input field in the attached
testcase) with a trunk build from today's source. However (comment 3) multiple
focus and blur events are being fired for the document. See the testcase in bug
164686 which doesn't confuse things with Alerts. The end of bug 164686 comment 2
describes event doubling (and tripling!)

Comment 6

16 years ago

*** This bug has been marked as a duplicate of 58441 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Hardware: PC → Macintosh
Resolution: --- → DUPLICATE
Whiteboard: DUPEME

Updated

16 years ago
QA Contact: rakeshmishra → trix

Comment 7

16 years ago
verifying dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.