Closed Bug 1629650 Opened 4 years ago Closed 4 years ago

nsFlexContainerFrame::ComputeFinalSize variable "reflowOutputInFlexWM" is mis-named

Categories

(Core :: Layout: Flexbox, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla77
Tracking Status
firefox77 --- fixed

People

(Reporter: dholbert, Assigned: TYLin)

References

Details

Attachments

(1 file)

Just noticed this when re-reading the implementation of nsFlexContainerFrame::ComputeFinalSize:

  // Compute flex container's reflow-output measurements (in its own
  // writing-mode), starting w/ content-box size & growing from there:
  LogicalSize reflowOutputInFlexWM =
      aAxisTracker.LogicalSizeFromFlexRelativeSizes(aContentBoxMainSize,
                                                    aContentBoxCrossSize);

This variable's name doesn't make sense. Its name use to be desiredSizeInFlexWM (which does make sense) but it was caught up in a slightly overzealous search-and-replace, in bug 1621989 part 1. (That search-and-replace meant to rename ReflowOutput-typed variables, which were traditionally often named "DesiredSize"; but this particular variable is not a ReflowOutput and is a "desired size", so it should not have been renamed.)

After bug 1627125 lands (which has a rewriting of this function), we should rename this particular variable back to desiredSizeInFlexWM or something like it.

I can take care of this.

Assignee: nobody → aethanyc
Status: NEW → ASSIGNED
Pushed by aethanyc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2796692264cd
Rename flex container's desired size back to desiredSizeInFlexWM. r=dholbert
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla77
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: