Closed Bug 1629904 Opened 1 year ago Closed 23 days ago

[False Negative] Password generation is not offered for new password field on weibo.com

Categories

(Toolkit :: Password Manager: Site Compatibility, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox75 --- disabled
firefox76 --- wontfix
firefox77 --- wontfix
firefox90 --- verified

People

(Reporter: andrei.purice, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [passwords:generation])

Affected Versions:
Nightly 77.0a1 (2020-04-14) (64-bit)
Beta 76.0b4

Affected Platforms:
Windows 7/10 x64
MacOS 10.14
Ubuntu 18.04

Steps to reproduce:

  1. Go to weibo.com and reach the Register account form
  2. Click on the New Password field from the site

Expected Result:
The autocomplete dropdown should be displayed for the New Password field with the Password Generation option

Actual Result:
Password Generation was not offered for the New Password field

Regression-Range:
Not a regression - doesn't work in Beta 75.

Notes:
Password field: <input node-type="password" action-data="" action-type="text_copy" name="passwd" type="password" class="W_input " value="">

Whiteboard: [passwords:generation]

According to its Tranco + Alexa ranking, this site is among the most popular (which we are currently defining to be the top 500).

Priority: -- → P1

Erik is working on a model update to potentially address this.

Assignee: nobody → erik
Assignee: erik → nobody

Assigning severity. Priority-wise we should still get to this sooner rather than later.

Severity: -- → S3

When testing the model update in bug 1638187 I found that this field was not being recognized (score: 0.5207634486061282).

It's worth noting that this is a live page, though, and these results have been somewhat flaky.

Bumping down to P2 since although this is a popular website, the issue is a false negative, not a false positive and the user can use the context menu as a fallback.

Priority: P1 → P2
Depends on: 1692980

This is fixed by Bug 1692980.

Status: NEW → RESOLVED
Closed: 23 days ago
Resolution: --- → FIXED

Verified-fixed on the latest Firefox Nightly 90.0a1 (BuildID: 0210530214555) on MacOS 10.15. The password generation is now offered for the field and it also works as expected.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.