Closed Bug 1629913 Opened 4 years ago Closed 4 years ago

[False Negative] Password generation is not offered for the Register password field on perfumania.com

Categories

(Toolkit :: Password Manager: Site Compatibility, defect, P2)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
mozilla78
Tracking Status
firefox75 --- disabled
firefox76 --- wontfix
firefox77 --- verified
firefox78 --- verified

People

(Reporter: andrei.purice, Unassigned)

References

(Blocks 1 open bug, )

Details

(Whiteboard: [passwords:generation])

Affected Versions:
Nightly 77.0a1 (2020-04-14) (64-bit)
Beta 76.0b4

Affected Platforms:
Windows 7/10 x64
MacOS 10.14
Ubuntu 18.04

Steps to reproduce:

  1. Go to perfumania.com and reach the Change Password form use Recover account for a registered username)
  2. Click on the New Password and Retype Password fields
    observe that new password field is auto filled with the saved password, looks like Bug 1623431

Expected Result:
The autocomplete dropdown should display the Password Generation option for both password fields

Actual Result:
Password Generation was not offered for the Password field, only for Retype

Regression-Range:
Not a regression of this implementation, it partially fixed Beta 75 behavior given that password generation was not offered for both fields there.

Notes:
Password field: <input type="password" value="" name="customer[password]" id="reset_password">

Whiteboard: [passwords:generation]

According to its Tranco + Alexa ranking, this site is not among the most popular (which we are currently defining to be the top 500).

Priority: -- → P2

When testing the model update yesterday I found that LoginAutoComplete#startSearch was not being hit on this page, meaning our Fathom ruleset was never being executed.

Today during retesting it worked as expected. This may be intermittently fixed by bug 1638187.

Can also confirm this is fixed on the latest Nightly 78 and RC 70, tested on Windows 10.
Severin, could you please change the flags to fixed for the affected versions?

Flags: needinfo?(severin.mozilla)

Updated. Thanks for verifying, Timea!

Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(severin.mozilla)
Resolution: --- → FIXED
Target Milestone: --- → mozilla78

Thanks Severin! Marking this as verified fixed based on Comment 4.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.