Closed Bug 1629928 Opened 2 years ago Closed 2 years ago

New address bar too narrow on narrow screens

Categories

(Firefox :: Address Bar, defect, P1)

75 Branch
defect
Points:
1

Tracking

()

VERIFIED FIXED
Firefox 77
Iteration:
77.2 - Apr 20 - May 3
Tracking Status
firefox77 --- verified

People

(Reporter: adamw, Assigned: mak)

References

(Blocks 2 open bugs, Regressed 1 open bug)

Details

Attachments

(3 files)

Attached image firefoxnarrow.png

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

Updated to Firefox with the new address bar, on my (Fedora Linux) system where Firefox is in a 1080x1920 window (maximized on a portrait-orientation FHD screen).

Actual results:

The autocomplete / suggestion / whatever list that appears when you start typing in the new address bar seems now to only ever render as wide as the address bar itself. Which on a 1080 wide window, with a search box and a few plugins, is only about 573 pixels wide. The margins and the 'fade out' effect on the right hand side of the list effectively eat a little more of that, to the point where you almost never get anywhere close to the full URL or full title of any page in the list. This is particular a problem for trying to sort through many similar URLs, for instance...Bugzilla bugs. See attached screenshot.

Expected results:

It should be possible for this UI element to be much wider, as it was in the previous design. I understand that this doesn't matter a lot if the window is very wide, as is often the case on landscape-oriented screens, but it's a big problem if it isn't.

Component: Untriaged → Address Bar

if you enlarge the search bar just a bit, the address bar should move to a 2 lines layout

oh, so I just happened to fall into an awkward corner? fun. I'll try that.

So I have to make the search box nearly two tabs wider before that feature kicks in, and by that point the address bar is so narrow it still feels awkward even with the two line layout :/ the old 'it pops over the entire horizontal width of the window' behaviour really felt much better for me.

We could evaluate further expanding the 2 lines layout threshold. We didn't go too far away because, as I explained, there will always be that corner where people would like us to epand it further. So we risk to enter a neverending race with the requests.
It is currently set at 500px, I'd be prone to bring it to 550px. I'll ask to our designer if that's ok.

Flags: needinfo?(mak)

Resetting severity to default of --.

Attached image spec

The spec stated we should wrap at 650px urlbar width, we do at 500px.

Flags: needinfo?(mak)
Blocks: 1630275
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Points: --- → 1

The wrapping threshold is all well and good, but even with the wrapping, I'm losing a lot of useful space compared to the old setup. I get that the old way can be almost too wide on a really wide screen, but could there not be some kind of logic like "if the box looks like it's going to be really narrow, but we actually have more width than that available, we pop out into the extra available space like we used to"?

A lot of users complained about the old layout anyway, because it was covering much of content, it's hard to satisfy everyone, we think the new layout with the wrapping and other various tweaks we made (stripping https://www for example and changing the ration between title and url) will be a good compromise.

Assignee: nobody → mak
Status: NEW → ASSIGNED
Blocks: 1620231
Priority: P2 → P1
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/96da8b66316e
Increase the threshold for wrapping urlbar results to a second line. r=harry

Comment on attachment 9142510 [details]
Bug 1629928 - Increase the threshold for wrapping urlbar results to a second line. r=harry

Beta/Release Uplift Approval Request

  • User impact if declined: This is one of the common complaints about the new design, so it may be nice to provide it sooner, considered the patch is trivial
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Just resize the window when the urlbar is open and check we wrap once the input field is smaller than 650px rather than smaller than 500px (wrap sooner)
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Trivial patch changing just one threshold
  • String changes made/needed:
Attachment #9142510 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77
QA Whiteboard: [qa-triaged]

Verified as fixed using latest Nightly 77.0a1 2020-04-23 under Win 10 64-bit, Mac OS X 10.14 and Ubuntu 18.04 64-bit.

Regressions: 1632911

This just replaced one problem by another, I'm now stuck with a huge mostly-empty white box whenever I want to search something.

It should be possible for this UI element to be much wider, as it was in the previous design.
could there not be some kind of logic like "if the box looks like it's going to be really narrow, but we
actually have more width than that available, we pop out into the extra available space like we used to"?

I suggested this a while ago: https://bugzilla.mozilla.org/show_bug.cgi?id=1601330. Sigh.

Comment on attachment 9142510 [details]
Bug 1629928 - Increase the threshold for wrapping urlbar results to a second line. r=harry

I'm clearing the uplift for now, this is non-critical and I'd like to further discuss with UX in spite of recent report.

Attachment #9142510 - Flags: approval-mozilla-beta?

Removing the flags since the patch will ride the 77 train.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Iteration: --- → 77.2 - Apr 20 - May 3
You need to log in before you can comment on or make changes to this bug.