Setting "-moz-binding: none" dynamically does not remove binding

RESOLVED DUPLICATE of bug 119078

Status

()

Core
XBL
P3
critical
RESOLVED DUPLICATE of bug 119078
15 years ago
4 years ago

People

(Reporter: José Jeria, Assigned: David Hyatt)

Tracking

(Blocks: 2 bugs, {dataloss, testcase})

Trunk
Future
x86
All
dataloss, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020813
BuildID:    20020813

Run testcase and go to Print Preview, the content in the Marquee will not be
visible. Its visible in Internet Explorer.

Reproducible: Always
Steps to Reproduce:
1. Run testcase
2. Go to Print Preview
(Reporter)

Comment 1

15 years ago
Created attachment 95554 [details]
Testcase
I suppose this would be related to bug 159932.
OS: Windows XP → All

Comment 3

15 years ago
This bug can be fixed by changing these lines in html.css

@media print {
      marquee { -moz-binding: none; }
}

to

@media print {
  marquee{
	-moz-binding:none;
	overflow:auto;
	display:block;
  }
}

This should probably also be merged into the print only rules just below.
Unfortuanly I don't know how to make patches so somebody else will have to do this.
In the meantime, a work around is to add the new lines to UserContent.css
(tested on build 2002081308, win95).

Comment 4

15 years ago
this was done on purpose
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Comment 5

15 years ago
Doron: can you give more details about why you think this is invalid?
Status: RESOLVED → REOPENED
Keywords: dataloss
Resolution: INVALID → ---
Summary: Marquee content not visible in print preview → Marquee content not visible after printing or in print preview

Comment 6

15 years ago
because, as you can see from the css, it was done on purpose

Comment 7

15 years ago
Doron: if by "the css" you mean
http://lxr.mozilla.org/seamonkey/source/layout/html/document/src/html.css#534, I
don't see a comment that says "don't print content inside marquee tags".  By the
way, "this was done on purpose" is never sufficient for marking a bug wontfix or
invalid.
Printing problem, over to rods.
Assignee: jst → rods
Status: REOPENED → NEW

Comment 9

15 years ago
543 @media print {
544   marquee { -moz-binding: none; }
545 }

Is pretty obvious I would say...
cc: hixie

Comment 11

15 years ago
Created attachment 95654 [details]
testcase that does not involve marquee

This is a -moz-binding bug, not a marquee bug.	Setting "-moz-binding: none"
dynamically does not remove a binding (testcase).

Is this bug 119078?
marquee { -moz-binding: none; } isn't supposed to hide the content, it's
supposed to make it not scroll. This is valid. The content should print just
like it did before we implemented scrolling marquee.

If it's a -moz-binding bug, please send reassign to XBL.
(Reporter)

Comment 13

15 years ago
Is this somehow related to bug 135653?

Comment 14

15 years ago
This will help when we start tackling printing for XBl, but right now we do not
support that that
Status: NEW → ASSIGNED
Priority: -- → P3
Summary: Marquee content not visible after printing or in print preview → (XBL-bindings) Marquee content not visible after printing or in print preview
Target Milestone: --- → Future

Comment 15

15 years ago
-> XBL
Assignee: rods → hyatt
Status: ASSIGNED → NEW
Component: DOM HTML → XBL
QA Contact: stummala → ian
Summary: (XBL-bindings) Marquee content not visible after printing or in print preview → Setting "-moz-binding: none" dynamically does not remove binding

Updated

15 years ago
Blocks: 161109

Comment 16

15 years ago
This looks like a dup of bug 119078. Reporter, please verify, and close this one
off if it is.

Comment 17

15 years ago
This might very well be a dupe of bug 119078, but the workaround suggested there
 (replace -moz-binding:none; with -moz-binding: url("");) doesn't work.

Updated

15 years ago
Blocks: 57805

Comment 18

15 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: normal → critical
(Reporter)

Updated

15 years ago
Keywords: testcase

Comment 19

13 years ago

*** This bug has been marked as a duplicate of 119078 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.