Last Comment Bug 163024 - bugzilla_email_append.pl calls processmail incorrectly
: bugzilla_email_append.pl calls processmail incorrectly
Status: RESOLVED FIXED
[fixed in 2.16.1] [fixed in 2.14.4] [...
:
Product: Bugzilla
Classification: Server Software
Component: Bugzilla-General (show other bugs)
: unspecified
: x86 Linux
: P1 critical (vote)
: Bugzilla 2.18
Assigned To: Bradley Baetz (:bbaetz)
: default-qa
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-16 03:38 PDT by Bradley Baetz (:bbaetz)
Modified: 2012-12-18 20:46 PST (History)
5 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch (696 bytes, patch)
2002-08-16 18:15 PDT, Bradley Baetz (:bbaetz)
bugreport: review+
mozpreed: review+
Details | Diff | Splinter Review

Description Bradley Baetz (:bbaetz) 2002-08-16 03:38:51 PDT
 
Comment 1 Bradley Baetz (:bbaetz) 2002-08-16 03:43:35 PDT
Bleh. Stupid enter key...

Anyway, as jussi pointed out in bug 160631, bugzilla_email_append.pl uses the
same quoting that bug_email.pl used, which was fixed for bug 154008:

system("cd .. ; ./processmail $found_id '$SenderShort'");

is not the way to go. We should fix that....
Comment 2 Bradley Baetz (:bbaetz) 2002-08-16 18:15:41 PDT
Created attachment 95666 [details] [diff] [review]
patch

This patch WFM. (modulo the usual bug_email bugs)
Comment 3 Gervase Markham [:gerv] 2002-08-16 22:56:27 PDT
What happened to "cd .."?

Gerv
Comment 4 Bradley Baetz (:bbaetz) 2002-08-16 23:02:12 PDT
Its not needed since bug 154008 went in - ie this is another breakage from that.
Comment 5 Joel Peshkin 2002-09-02 23:30:04 PDT
Comment on attachment 95666 [details] [diff] [review]
patch


r=joel assuming that someone has confirmed that the routined still does its
desired function.
Still need a seperate 2xr for 2.16 branch.
Comment 6 J. Paul Reed [:preed] 2002-09-02 23:43:43 PDT
Comment on attachment 95666 [details] [diff] [review]
patch

People still use this stuff?!

Wild.

r2=preed
Comment 7 Bradley Baetz (:bbaetz) 2002-09-02 23:49:08 PDT
Yes, people still use this (unfortunately)

Checked in to trunk and 2.16/2.14 branches
Comment 8 J. Paul Reed [:preed] 2002-09-17 09:48:02 PDT
Removing security bit for publication in status report.
Comment 9 Bradley Baetz (:bbaetz) 2002-09-17 16:18:33 PDT
Err... Weren't we waiting for 2.16.1 before removing the sceuirity bit? Readding
the security bit for now....
Comment 10 Dave Miller [:justdave] (justdave@bugzilla.org) 2002-10-01 09:53:06 PDT
Security Announcement is posted.  removing the security bit.

Note You need to log in before you can comment on or make changes to this bug.