Closed Bug 1630337 Opened 5 months ago Closed 5 months ago

Twisty icons are cut off in the buddy list sidebar

Categories

(Chat Core :: General, defect)

defect

Tracking

(Not tracked)

RESOLVED FIXED
Instantbird 77

People

(Reporter: aleca, Assigned: aleca)

Details

(Keywords: regression)

Attachments

(2 files, 2 obsolete files)

After the update of the twisty from m-c, the size of those icons don't match the container anymore.
Since we're using that SVG as a background image, this can be easily fixed with a background-size: contain property.

Attached patch conversation-twisty.diff (obsolete) — Splinter Review
Attachment #9140811 - Flags: review?(richard.marti)
Attached patch conversation-twisty.diff (obsolete) — Splinter Review

Small typo in the commit message.

Attachment #9140811 - Attachment is obsolete: true
Attachment #9140811 - Flags: review?(richard.marti)
Attachment #9140812 - Flags: review?(richard.marti)
Comment on attachment 9140812 [details] [diff] [review]
conversation-twisty.diff

Review of attachment 9140812 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.

::: mail/components/im/themes/chat.css
@@ +752,5 @@
>  
>  /* from instantbird/themes/blist.css */
>  richlistitem[is="chat-group-richlistitem"] .twisty {
>    padding-top: 1px;
> +  width: 10px; /* The image's width is 8 pixels */

The width is now 10 pixels. Or remove the comment because the image (twisty-*.svg) width is 12px in reality.
Attachment #9140812 - Flags: review?(richard.marti) → review+
Attachment #9140812 - Attachment is obsolete: true
Attachment #9140816 - Flags: review+
Target Milestone: --- → Instantbird 77

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/cb41490f1491
Fix twisty icon size in chat conversation richlist. r=Paenglab

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.