Opening already downloaded IMAP message in separate window is slow

RESOLVED WORKSFORME

Status

MailNews Core
Networking: IMAP
RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: Fredrik Aminoff, Assigned: Bienvenu)

Tracking

({perf})

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When opening a large mail (~800kb, no attachement) over an IMAP-connection
Mozilla seems to download the whole message again. I have already downloaded and
see it in the preview-pane so Mozilla should be able to open it fast. Mozilla
seems to hang with 100% CPU usage and "Loading Document" and the new blank
mail-window. After a very long time the mail is shown and the CPU-usage drops.

Using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020814

Updated

15 years ago
QA Contact: huang → gchan

Updated

15 years ago
Keywords: perf
Summary: Open already downloaded (IMAP) mail in seperate window is slow → Opening already downloaded IMAP message in separate window is slow

Comment 1

15 years ago
i got sort of the same problem - without the cpu usage - the message just
downloads itself again when opening in new window, eventhough i've just viewed
it in preview-pane.

Comment 2

14 years ago
Build 2003100804
Windows XP
AMD1000

I get the same behavior on this build as well.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: MailNews → Core

Comment 3

10 years ago
Nikolay - pretty sure this is a dupe
Assignee: mscott → bienvenu
QA Contact: grylchan → networking.imap
Whiteboard: dupeme

Comment 4

10 years ago
Wayne, I don't recall any dupes right now, but had personal problems with early 2.0.0.0(4) and probably with latest 2.0.0.12 2 weeks ago.

Comment 5

9 years ago
I was about to dupe this against bug 345832 when noticing "no attachments" in the original description, thus not sure if this is the same mechanism.

Also, introduction of an IMAP disk cache (bug 439731) or using off-line storage by default (bug 385502) may resolve this issue as well.
Product: Core → MailNews Core
Fredik do you still encounter the issue with recent builds of thunderbird ? (http://www.mozillamessaging.com/en-US/thunderbird/early_releases/ to find such a beast)
(Reporter)

Comment 7

9 years ago
I've gotten a fairly much faster computer since 2002, so the problem is not as easy to duplicate anymore. :)

Running "version 2.0.0.19 (20081209)" I did however still see this to some extent. However not always and not in the same problematic way.Some of my mails did load slow when opening up them in a seperate window with a "loading message" status.

To summarize. If you would like to close this bug based on the above, it would be OK with me.
(Assignee)

Comment 8

8 years ago
storing messages offline by default helps here a lot. Marking wfm.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.