Closed Bug 1630455 Opened 2 years ago Closed 2 years ago

[Wayland] Firefox tabs crashing

Categories

(Core :: Widget: Gtk, defect, P2)

75 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1628110

People

(Reporter: michelesr, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

Actual results:

tab crashed, bug reported higlighted issues with XQueryExtension, libX11, libGTK, and so on... I'm running Arch Linux and this started happened recently, and can be reproduced with firefox-esr too:

Expected results:

tab shouldn't have crashed

Also opening "about:support" page will make Firefox crash totally.

This doesn't happen in safe mode, but it happens on a fresh profile (without 3rd party extensions).

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Blocks: wayland
Priority: -- → P2
Crash Signature: [@ _XGetRequest ]
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
See Also: → 1628110

Also Firefox on wayland will always crash at startup when "layers.acceleration.force-enabled" is true: https://crash-stats.mozilla.org/report/index/5b84f28a-811c-472d-ad18-0a5540200416

Crash Signature: [@ _XGetRequest ]
OS: Linux → Unspecified
Hardware: x86_64 → Unspecified
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Crash Signature: [@ _XGetRequest ]

An Arch user discovered that the wrong library is loaded in the case popcorntime is installed in the system. Removing popcorntime will solve the problem.

https://bbs.archlinux.org/viewtopic.php?id=254633

However, https://bugzilla.mozilla.org/show_bug.cgi?id=1628110 is still happening.

Actually, I was wrong. After removing popcorntime and rebooting, Firefox is working properly with Wayland and "layers.acceleration.force-enabled" set to true. Even webrender and dmabuf vaapi are working fine.

My apologies for the confusion.

Thanks for finding this out!

Status: UNCONFIRMED → RESOLVED
Crash Signature: [@ _XGetRequest ]
Closed: 2 years ago
Resolution: --- → DUPLICATE
See Also: 1628110
Duplicate of bug: 1628110
You need to log in before you can comment on or make changes to this bug.