Closed Bug 1631193 Opened 4 months ago Closed 4 months ago

Firefox Beta does not start on Wayland

Categories

(Release Engineering :: Release Automation: Other, defect)

Desktop
Linux
defect
Not set
normal

Tracking

(firefox76 verified, firefox77 fixed)

VERIFIED FIXED
Tracking Status
firefox76 --- verified
firefox77 --- fixed

People

(Reporter: b, Assigned: b)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:76.0) Gecko/20100101 Firefox/76.0

Steps to reproduce:

  1. Install org.mozilla.firefox from Flathub Beta
  2. Start it from Wayland session (tested on GNOME)

Actual results:

Firefox does not start; "Error: no DISPLAY environment variable specified" is printed in terminal

Expected results:

Firefox actually starts

Component: Untriaged → Release Automation: Flatpak
OS: Unspecified → Linux
Product: Firefox → Release Engineering
Hardware: Unspecified → Desktop
Version: 76 Branch → other

Firefox still does not default to Wayland when it's available (or when
X11 socket is not accessible). This can be changed by MOZ_ENABLE_WAYLAND=1
but as it's not the default, it's safer to just drop access to Wayland.

Assignee: nobody → b

Changing fallback-x11 to x11 should be enough to fix this issue. Leaving --socket=wayland will make testing wayland easier for users without downsides.

As users need to define an environment variable with override command, I find it largely irrelevant. It’s about fixing the regression.

It's relevant for users who come from distro package and have no idea about special wayland permission needed for flatpak.

--socket=wayland was added because users requested to add it and it doesn't cause any harm. --socket=x11-fallback does harm and it's the only one that needs to be removed.

Given that --socket=wayland is essentially useless without defining the variable, I still don't see why it should be included. Useless permissions cause harm.

Firefox can run on wayland, on fedora it even uses wayland by default. The fact that not everyone will run it on wayland doesn't mean nobody will run it on wayland. How wayland permission is useless then? It's not like wayland permission decreases sandbox security unlike x11.

Pushed by mtabara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fc4ad3fce1b7
drop Wayland permissions from flatpak r=mtabara

Comment on attachment 9141479 [details]
Bug 1631193 - drop Wayland permissions from flatpak r=mtabara

Beta/Release Uplift Approval Request

  • User impact if declined: Flatpak fix.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce: Flatpak fix.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Flatpak fix.
  • String changes made/needed:
Attachment #9141479 - Flags: approval-mozilla-beta?

Comment on attachment 9141479 [details]
Bug 1631193 - drop Wayland permissions from flatpak r=mtabara

Approved for 76.0b7.

Attachment #9141479 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
QA Contact: daniel.cicas

Hello
I can confirm that this issue is fixed on Fx 76.0b7 on Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Component: Release Automation: Flatpak → Release Automation: Other
You need to log in before you can comment on or make changes to this bug.