Closed Bug 1632030 Opened 3 years ago Closed 2 months ago

Network's raw headers text selection doesn't persist

Categories

(DevTools :: Netmonitor, defect, P3)

defect

Tracking

(firefox107 fixed)

RESOLVED FIXED
107 Branch
Tracking Status
firefox107 --- fixed

People

(Reporter: Harald, Assigned: vaga, Mentored, NeedInfo)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(2 files, 2 obsolete files)

STR: Select text in the raw header text.
AR: Text selection doesn't persist.

Right now its an textarea. The click event in the TreeView seems to reset the selection.

Best fix might be switching to a CodeMirror instance with http highlighting, in which case we can dupe this against bug 1618070.

Bomsy, would this be a good first bug with some mentoring?

Flags: needinfo?(hmanilla)
Mentor: hmanilla

Hey :bomsy I would like to take this bug.

As mentioned above the TextArea has to be replaced with SourcePreview, right?

Below is what it should be replaced with,

SourceView({
    text: value,
    mode: 'http'
})

Please let me know if there's something I am missing out here.

Thanks.

Nice. I've assigned to you.(In reply to Harshil from comment #3)

SourceView({
    text: value,
    mode: 'http'
})

should be SourcePreview. apart from that. That looks correct

Assignee: nobody → ghagrawal17

Here is a screencast of what the issue is
http://g.recordit.co/BI8SFrN35E.gif

Hey :bomsy,

I recently submitted a patch for one of the bugs, and I am waiting for it to get reviewed. Should I wait for it to get reviewed and then start working on this? Those changes are not related to this, and are completely different, but I wanted to know how the developer flow is. I would appreciate if you could help me understand it better.

Thanks.

Hey Harshil
No you don't need to wait for it to get reviewed.
You can start another patch , probably do hg up central and the hg commit on that when you are done.

Hey Hubert,
Thank you for the information. When I try to run hg up central I get an error abort: unknown revision 'central'!. I checked the extensions for hg and firefoxtree is configured. Not sure what is wrong here.

The severity field is not set for this bug.
:Honza, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(odvarko)
Severity: -- → S3
Flags: needinfo?(odvarko)

This good-first-bug hasn't had any activity for 6 months, it is automatically unassigned.
For more information, please visit auto_nag documentation.

Assignee: ghagrawal17 → nobody

I wanted to fix this https://bugzilla.mozilla.org/show_bug.cgi?id=1696128 But then ended up looking at this https://bugzilla.mozilla.org/show_bug.cgi?id=1632030 which is a dupe of the current bug.

I see the current bug had somebody working on it, has a patch but never got merged. Can I pick it up? Will the owner continue? Why was the work paused?

Assignee: nobody → ghagrawal17
Status: NEW → ASSIGNED

Yes, please, help welcome on this one.

Thank you,
Honza

Hi Petcuandrei,
There has been no response from Harshil, i think you can pick this up if you like.

Thanks

Flags: needinfo?(petcuandrei)

I'll pick this up then. Thank you.

Flags: needinfo?(petcuandrei) → needinfo?(hmanilla)

OK assigned to you.

Assignee: ghagrawal17 → petcuandrei
Flags: needinfo?(hmanilla)

This good-first-bug hasn't had any activity for 2 months, it is automatically unassigned.
For more information, please visit auto_nag documentation.

Assignee: petcuandrei → nobody
Status: ASSIGNED → NEW

Hi,
I would like to work on this bug.

Flags: needinfo?(odvarko)
Flags: needinfo?(hmanilla)
Flags: needinfo?(odvarko)

Assigned to you, thank you for helping.

Honza

Assignee: nobody → fabien
Status: NEW → ASSIGNED
Flags: needinfo?(hmanilla)

The second patch fix the bug. (https://phabricator.services.mozilla.com/D119782)
As discussed with @nchevobbe, I can create a new bug to add SourcePreview.

Flags: needinfo?(hmanilla)
Attachment #9230957 - Attachment description: Bug 1632030 - Network's raw headers text selection doesn't persist r?bomsy → Bug 1632030 - Replace textarea to `SourcePreview` component to show raw headers r?bomsy

Comment on attachment 9231201 [details]
Bug 1632030 - Add Code Mirror HTTP mode in SourceEditor r?bomsy

Revision D119904 was moved to bug 1721126. Setting attachment 9231201 [details] to obsolete.

Attachment #9231201 - Attachment is obsolete: true
Flags: needinfo?(hmanilla)

This good-first-bug hasn't had any activity for 2 months, it is automatically unassigned.
For more information, please visit auto_nag documentation.

Assignee: fabien → nobody
Status: ASSIGNED → NEW

Hi, I'd love to work on this, could it be assigned to me?

@bomsy: are you working on this one? (or should we re-assign?)

Flags: needinfo?(hmanilla)
Assignee: nobody → fabien
Status: NEW → ASSIGNED

I've pinged Fabien in the bug. It's close i think it just needs a rebase to land. If he is not able to complete, i'll complete and land it.

Flags: needinfo?(hmanilla)

Hi,

The main bug is fixed by D119782 in Phabricator. (https://phabricator.services.mozilla.com/D119782)

The two others patchs add the colorscheme in raw HTTP header.
But I catch an another bug in my patch D119761: when we toggle the raw headers, the panel content shifts because CodeMirror take a few milliseconds to build the HTML. There is a video on my comment : https://phabricator.services.mozilla.com/D119761#3927260

It seems good. :)

Flags: needinfo?(hmanilla)

This good-first-bug hasn't had any activity for 2 months, it is automatically unassigned.
For more information, please visit auto_nag documentation.

Assignee: fabien → nobody
Status: ASSIGNED → NEW

Hi Hubert

I would like to work on this issue. Could you please assign it to me?

Assignee: nobody → fabien
Status: NEW → ASSIGNED
Pushed by hmanilla@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4420b5bc7a00
Network's raw headers text selection doesn't persist r=bomsy

I also worked to replace textarea by SourcePreview. It was never landed.
https://phabricator.services.mozilla.com/D119761

Keep me informed.

Comment on attachment 9230957 [details]
Bug 1632030 - Replace textarea to SourcePreview component to show raw headers r?bomsy

Revision D119761 was moved to bug 1795011. Setting attachment 9230957 [details] to obsolete.

Attachment #9230957 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch
You need to log in before you can comment on or make changes to this bug.