Closed Bug 1632242 Opened 5 months ago Closed 4 months ago

Mention results for groups in errorsummary even when the group passed or was skipped

Categories

(Firefox Build System :: Task Configuration, task)

task

Tracking

(firefox78 fixed)

RESOLVED FIXED
mozilla78
Tracking Status
firefox78 --- fixed

People

(Reporter: marco, Assigned: marco)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Currently errorsummary.log contains a test_groups line containing the groups which were part of the task, and a test_result line for every test where the actual result was not the same as the expected result.

This makes it hard to know which groups actually run, as the groups in test_groups with no corresponding test_result line could either have run and passed or they could have been skipped.

Duplicate of this bug: 1634159
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Pushed by mcastelluccio@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa7b0d6cd464
Mention results for groups in errorsummary even when the group passed or was skipped. r=ahal

I've verified this is working well for all test suites (except WPT, for which we only mention passed groups for now, probably same root cause as bug 1631515, but that's good enough for now: I can assume any group which is not mentioned to be skipped).

Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla78
Depends on: 1646761
You need to log in before you can comment on or make changes to this bug.